Wait.ForExist doesn't work

4 posts, 0 answers
  1. aplicaciones
    aplicaciones avatar
    38 posts
    Member since:
    Apr 2017

    Posted 03 Nov 2017 Link to this post

    Hello,

    I'm experiencing issues with a "Wait.ForExists" step. I've set this step to wait 60sec for the element im looking for. But it produces a "Element Not found!" exception before this 60sec are through (it waits around 15sec). In addition I added a simple wait step before the "Wait.ForExist" step and it worked just fine. I understand that this proves that the element identification is correct.

    Could you give me some guidance or any hint on this.

    Regards,
  2. Nikolay Petrov
    Admin
    Nikolay Petrov avatar
    308 posts

    Posted 08 Nov 2017 Link to this post

    Hello,

    In general the work-flow in such scenario is to use step property Timeout value with priority during the execution. Please refer to the attached screenshot. 

    I hope this clarification helps.

    Best Regards,
    Nikolay Petrov
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. aplicaciones
    aplicaciones avatar
    38 posts
    Member since:
    Apr 2017

    Posted 08 Nov 2017 in reply to Nikolay Petrov Link to this post

    Hello,

    I am already using the property Timeout as you specify. In fact, that is what I think does not work as intended.

    Could there be anything else that is producing this error?

    Best regards,
  4. Nikolay Petrov
    Admin
    Nikolay Petrov avatar
    308 posts

    Posted 13 Nov 2017 Link to this post

    Hello,

    Unfortunately I could not produce reported behavior. Even if the test is located in a test list or used as a step the Wait step property "Timeout" should be respected. I use latest at the moment version of the product 2017.3.1010. 

    Would you share more details on how to reproduce such problem on our end please? Is this element in a frame or you are accessing it trough the Pages? Please provide a screen-shot of the element and the step. Do you use "EnsureStateIsCurrent" enabled on the wait step?

    Thank you in advance for providing the information.

    Best Regards,
    Nikolay Petrov
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top