This is a migrated thread and some comments may be shown as answers.

RESULT_CODE_KILLED_BAD_MESSAGE

3 Answers 2013 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Ron
Top achievements
Rank 1
Veteran
Ron asked on 07 Dec 2020, 06:25 PM

I installed the test studio extension on both chrome and edge (chromium). Unfortunately after loading the extension when trying to record a test, I get a  RESULT_CODE_KILLED_BAD_MESSAGE error message on both browsers. Even after removing the extension from both browsers, this error remains when I try to visit the URL that I tried recording. Not only am I very disappointed in the extension not working properly (the extension works on Firefox but refuses to record half the mouse clicks, but that;s a different story), but I would like my browsers to work properly again. Can anyone please help fix my browsers?

3 Answers, 1 is accepted

Sort by
0
Plamen Mitrev
Telerik team
answered on 08 Dec 2020, 03:27 PM

Hello Ron,

I am sorry to hear about the encountered error when accessing the application under test. This is not something we have encountered before and no other users have reported such misbehavior. I will do my best to help you get things back to normal and use Test Studio for test automation.

One of the initial steps that you need to do before using Test Studio for recording and execution, is to prepare the browsers. You need to add the Test Studio extension and calibrate your browser to ensure that the behavior will be stable and as expected.

It seems to me that the application under test or the browser's user profile and settings are specific and something there causes the issue. As you mentioned, you removed the extension, but the result is the same. I will suggest that you restore the calibration of Chrome and Edge Chromium browsers, by clicking the "Restore" button. That will revert the calibration changes.

Another suggestion is to clear the User Data for both Chrome and Edge Chromium browsers on your machine and allow the browsers to regenerated their Default profile. To do that, you need to close all instances of the browsers and delete the whole User Data folder, for me Chrome's data is in "C:\Users\mitrev\AppData\Local\Google\Chrome\User Data".

In case you continue to experience any troubles, please share more details on the topics below.

  • Share additional information about the encountered error and if it is reproduced on other applications, as well.
  • Do you have custom user profiles in Chrome browser?
  • Does the application under test have Cross-domain iFrames? That would explain the issues with Firefox, as it restricts actions against iFrames from different domain.
  • Is it possible to provide temporary access to the application under test, or sample application that reproduces the same issue? I would be able to analyze it further and troubleshoot it on my end.

I am looking forward to hearing from you and continue our discussion.

Regards,
Plamen Mitrev
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Test Studio course! Check it out at https://learn.telerik.com/.
0
Ron
Top achievements
Rank 1
Veteran
answered on 08 Dec 2020, 05:01 PM

Hi Plamen,

Unfortunately my colleague is experiencing exactly the same problem, so it's definitely not a freak incident. Concerning restoring the browsers to a working state, restoring from Test Studio worked for Edge but not for Chrome. I had to remove my profile and that did fix that problem. Unfortunately I lost all settings in that process, so I'm not particularly happy about that.

Calibration has been done for all browsers and Test Studio didn't complain about anything. Both for me as well as my colleague.

To answer you questions:

 

 

  • Do you have custom user profiles in Chrome browser? No, we dont'
  • Does the application under test have Cross-domain iFrames? That would explain the issues with Firefox, as it restricts actions against iFrames from different domain. No, the entire application runs in the same domain. We do use a lot of frames and iframes (due to legacy) but again, no cross-domain iframes.
  • Is it possible to provide temporary access to the application under test, or sample application that reproduces the same issue? I would be able to analyze it further and troubleshoot it on my end. Before we go there, I would like to see the extensions working in both chrome and firefox. Without it, I feel that Test Studio is useless for us. Not only does it limit our recording posibilities but we would severely doubt the trust of quality of the product. I did make a private ticket for this issue. Maybe it is a good idea to organize a meeting, during which we can discuss things and we could grant you remote access to our computers as well as the application itself. So please contact me privately to organize that.

Kind regards,

Ron

0
Plamen Mitrev
Telerik team
answered on 09 Dec 2020, 01:18 PM

Hi Ron,

I can imagine how you must be feeling after encountering this issue and especially when it happens for both you and your colleague. It is not expected for our extension or calibrations to cause those issues and none of our users have reported this. Nevertheless, I will be happy to investigate this further.

Thank you for your follow up on the topics and questions I had before. I assume that providing access to the application under test will be more complex. As you suggested, we can organize an online meeting and explore the issue further on your end. I will provide a time slot for a meeting in the private ticket and we can continue our discussion there.

Your understanding and cooperation is much appreciated!

Regards,
Plamen Mitrev
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Test Studio course! Check it out at https://learn.telerik.com/.
Tags
General Discussions
Asked by
Ron
Top achievements
Rank 1
Veteran
Answers by
Plamen Mitrev
Telerik team
Ron
Top achievements
Rank 1
Veteran
Share this question
or