This is a migrated thread and some comments may be shown as answers.

Requested registry access is not allowed

6 Answers 90 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
venkat
Top achievements
Rank 1
venkat asked on 10 Jan 2011, 09:06 PM

hi,
I get this message when i try to click the register button in configure execution server.

I am part of the admin groups. do you know Why i get this.


Thanks
Venkat

6 Answers, 1 is accepted

Sort by
0
Stoich
Telerik team
answered on 12 Jan 2011, 01:27 PM
Hello Venkat,
     you need to be logged in with an Administrator account in order to register a machine as an Execution Server.
Please make sure you're running with Administrative rights and try again.

Let me know if the problem persists.

Regards,
Stoich
the Telerik team
Interested in Agile Testing? Check out Telerik TV for a recording of Automated Testing in the Agile Environment
0
jkeller
Top achievements
Rank 1
answered on 10 Aug 2011, 06:57 PM
I do not have administrative rights and need to be able to run 'open in visual studio' and 'run sample' links from OpenAccess ORM SDK.  Are there instructions /proceduire i can give to my network admin group to fix/set . I access this server via RDP/Terminal Server and am not part of the localadmin group.

Thanks in advance

John Keller
0
Cody
Telerik team
answered on 11 Aug 2011, 06:05 PM
Hello Jkeller,

See if your network admin group can add your domain account as a member of the local administrators group on the machine you're trying to run the software on, as shown in the attached screenshot.

All the best,
Cody
the Telerik team
Vote for Telerik Test Studio at the Annual Automation Honors Voting!
0
Chris
Top achievements
Rank 1
answered on 02 Jan 2013, 05:29 PM
I discovered the answer to my problem below.  On the server, even though I am an administrator, I needed to right click the Configure as Execution Server and select Run as Administrator.  That worked.  Also, you can right click the Configure as Execution Server/Properties/Compatibility tab and select to Run this program as administrator and it will run it that way in the future.  The latter would be a good step after the Scheduling Server and Execution Server are installed.  This was a simple fix but I missed it.

Problem (solved):
I'm a member of the Administrators group on our server (Windows Server 2008 Service Pack 2).  My Test Studio project indicated no execution server when trying to run a test list.  The project already indicated successful connection.

Logged on the server.
Clicked Configure as Execution Server
Warning:  The Execution Server must be run with Administrative privileges otherwise it might not function properly!
Clicked OK
Alert box:  Requested registry access is not allowed.
Telerik Test Studio Execution Server pop up opens
Click checkbox:  Start Execution Server when Windows starts
Alert box:  Requested registry access is not allowed
Click OK
Check box is checked
On project test list on local computer click Run List Remotely
Server shows error
Mouseover:  NoExecutionServer

What else do I need to check since my account has full privileges?  (Project connection to scheduling server already checked and registered.  Scheduling Server and Execution Server on same server)

Thanks,
Chris
0
Cody
Telerik team
answered on 02 Jan 2013, 07:14 PM
Hello Chris,

That is wonderful news! Thank you for the update. As a result of your discovery I've filed this bug report.

Regards,
Cody
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Ahmed
Top achievements
Rank 1
answered on 24 Jul 2018, 02:39 PM
Shit + Right click key on VS icon and run as administrator.  Then run your toolbox setup.  should not have any issues.
Tags
General Discussions
Asked by
venkat
Top achievements
Rank 1
Answers by
Stoich
Telerik team
jkeller
Top achievements
Rank 1
Cody
Telerik team
Chris
Top achievements
Rank 1
Ahmed
Top achievements
Rank 1
Share this question
or