This is a migrated thread and some comments may be shown as answers.
Recording problems
29 Answers 153 Views
This is a migrated thread and some comments may be shown as answers.
Tyrone
Top achievements
Rank 1
Tyrone asked on 18 Aug 2010, 09:38 AM
I have a problem recording my app, the record works with a random silverlight site, but as soon as I use it with my own project,

"Unable to connect to Silverlight application. Silverlight recording will not function"

??

29 Answers, 1 is accepted

Sort by
0
Konstantin Petkov
Telerik team
answered on 18 Aug 2010, 09:58 AM
Hi Tyrone,

Thank you for choosing to evaluate WebUI Test Studio.

I have to confirm I've seen this error before but we should be good to go with the latest builds. Can you please try the latest internal build available for download at this page in your account? Please let us know whether it works fine for you as well or if you need any other assistance.

Greetings,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 18 Aug 2010, 11:44 AM
Hi guys, I tried the latest internal build, and now

"Operation could not complete" error

- Automation Design Canvas 2.0
- WebAii 2.0 and/or WebAii Free Framework
- WebUI Test Studio 2010.1 and if any WebUI Test Studio Q3 version is still installed

This is from another post relating to that problem, This is what you recomended, uninstalling in that order, I do not have the first 2 items with my installation? Im not sure if the problem now pertains to this at all.
0
Konstantin Petkov
Telerik team
answered on 18 Aug 2010, 11:50 AM
Hi Tyrone,

Just to confirm, you have uninstalled the version you had and installed the latest internal build? The installer should detect the product is already installed in general but I'm not sure if that detection worked for you.

Can you uninstall any currently installed WebUI Test Studio version and install the latest build on that clean environment please? Let us know if that helps.

All the best,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 18 Aug 2010, 01:42 PM
Hi,

have reinstalled everything, when I try and run my app, as soon as the browser blasts off, a pop up showing the silverlight logo and the words "Silverlight detected, configuring" appears

I still cannot get the storyboards to render images of my app and any subsequent pages, unless I change the url to something completley differnt.
I have successfully used this tool yesterday against a silverlight site, but it will not work with the app I am testing.
And then I tried running it with this site: http://www.meworks.net/sl/ , without any success (Something completley random)

I am running with VS2010 and XP

??
0
Konstantin Petkov
Telerik team
answered on 18 Aug 2010, 02:48 PM
Hi Tyrone,

Thanks for posting this SL site. The recorder also fails to connect for me on that site so it seems we're still missing some SL detection info for specific scenarios. I'll log a bug immediately and update this thread as soon as we have a build that resolves the problem.

Best wishes,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Konstantin Petkov
Telerik team
answered on 18 Aug 2010, 04:32 PM
Hi Tyrone,

Just got the developers response. The problem with this site is this application is not a .xap file. It looks like an SL1 style Javascript + XAML deployment. We do not support this type of application.

Does your other site you've troubles with launch a regular SL3 or v4 application instead?

Regards,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 19 Aug 2010, 07:56 AM
Hi Konstantin,

"Does your other site you've troubles with launch a regular SL3 or v4 application instead?"

could you elaborate on this, I dont know what you mean by v4 app? I have Silverlight 4 installed aswell.
0
Konstantin Petkov
Telerik team
answered on 19 Aug 2010, 08:01 AM
Hi Tyrone,

The question is if this is a regular .xap base Silverlight app you have troubles recording on. The developers in charge should be able to confirm.

Kind regards,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 19 Aug 2010, 10:55 AM
Hi,

Our app is a .xap file
0
Konstantin Petkov
Telerik team
answered on 19 Aug 2010, 11:02 AM
Hi Tyrone,

Thanks for your confirmation.

May I ask you please to try running the latest custom build instead? You can find it available for download here. Let us know if this helps or you still get the problem with that build.

Thank you for your time and cooperation!

Greetings,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 19 Aug 2010, 12:15 PM
Hi,

I am needing the developer edition, that specific version was for the QA edition, so unless instructed otherwise I am going back to install it now again.
0
Konstantin Petkov
Telerik team
answered on 19 Aug 2010, 12:18 PM
Hi Tyrone,

The Dev Edition is available as well. Just change the "QA" with "Dev" in the address:

http://www.telerik.com/download/TestStudio/Telerik.WebUI.TestStudio.Dev.2010.2.818.msi

I sent you the QA since the ticket was submitted for that product.

Regards,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 19 Aug 2010, 12:22 PM
Sorry bout the confusion, busy with the installation, I will give it another go as soon as its complete.
Just to re-iterate, what we are working on , is in fact a .xap base Silverlight app.

Thanks
0
Tyrone
Top achievements
Rank 1
answered on 20 Aug 2010, 12:18 PM
Hi Guys,

The latest download does not work, I am getting "Operation could not complete" now.

???
0
Christopher
Telerik team
answered on 20 Aug 2010, 05:48 PM
Hi Tyrone,

Are you getting this message when you click the download link or during installation?

Greetings,
Chris
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 23 Aug 2010, 07:58 AM
Hi Guys,

This problem occurs after installation when I am attempting to create a test project.
0
Konstantin Petkov
Telerik team
answered on 23 Aug 2010, 09:07 AM
Hi Tyrone,

Creating a test project with the Dev Edition is a task of Visual Studio. Do you still get this problem? If so you may need to check whether a VS repair can help.

Please let us know of your findings.

Regards,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 23 Aug 2010, 12:59 PM
Hi guys, a repair wasnt needed, but I am still running into the issue when I record , that your tool is unable to connect to the Silverlight application. And just to re-iterate, our code is xap based like you asked.

0
Konstantin Petkov
Telerik team
answered on 23 Aug 2010, 01:23 PM
Hi Tyrone,

Thanks for the update. It will be highly appreciated if you can grant us access to the application. This way we can debug the problem and get back to you with resolution as soon as possible. You can submit a formal support ticket to share credentials or any additional info in private if needed.

Looking forward to hearing from you,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 24 Aug 2010, 02:49 PM
0
Tyrone
Top achievements
Rank 1
answered on 25 Aug 2010, 07:38 AM
Hi Konstantin,

Please mail me so I can give you log on details.

Thanks
0
Konstantin Petkov
Telerik team
answered on 26 Aug 2010, 10:01 AM
Hi Tyrone,

Thanks for sharing the application.

We could not reproduce the described problem though. We tried on a few machines running the latest build and got no error on loading the page to record.

Do you still get the problem? Can you please share details about your environment -- OS / Browser / Silverlight version / whatever else makes sense? Also can you try that on another machine in your network if possible as well?

Greetings,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 27 Aug 2010, 10:12 AM
Hi Guys,

Im running XP Pro, sp3
IE 8
Silverlight 4
VS2010
IIS 5.1

Let me know if you need anything else.

Shot
0
Nikolai
Telerik team
answered on 27 Aug 2010, 11:27 AM
Hi Tyrone,

I tested our recorder with your Silverlight app. and everything seems to be work fine.(see attachment) 
You can try our latest builds. They contain a lot of bug fixes so this might help in your case:

http://www.telerik.com/download/TestStudio/Telerik.WebUI.TestStudio.QA.2010.2.827.msi

http://www.telerik.com/download/TestStudio/Telerik.WebUI.TestStudio.DEV.2010.2.827.msi




Kind regards,
Nikolai
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 27 Aug 2010, 12:48 PM
Hi Guys,

That earlier support call pertained to the result that I recorded on my local dev environment.
Using that URI I supplied you with (Staging environment), the only thing that I do not see are the storyboards, but button clicks etc all get recorded successfully. So at least I am closer to a result.

Any ideas?

Thanks for your patience.
0
Konstantin Petkov
Telerik team
answered on 27 Aug 2010, 01:57 PM
Hi Tyrone,

I'm glad we have some progress with that issue.

Can you elaborate more on the storyboard issues? Do you get black images? What steps does this issue affect?

Also you can try the recapturing feature. The Recapture Storyboard button on the very right in the Record View should initiate a complete test storyboard recapturing. Does that help?

Greetings,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tyrone
Top achievements
Rank 1
answered on 01 Sep 2010, 12:52 PM
Hi guys,

sorry for the delay in response.

Yes there are black story boards coming up, I havnt tried the recapture button as yet, will do.
Bear in mind this is code in production environment which leads me to ask if you could explain if any configuration on my part needs to be done to run my app from my ide and have the web aii function.

Thanks

0
Konstantin Petkov
Telerik team
answered on 02 Sep 2010, 07:57 AM
Hello Tyrone,

No, there is no additional setup needed to get the right images in the Storyboard. The recapturing storyboard images option is added just for that purpose though so please give it a go.

Best wishes,
Konstantin Petkov
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Abhash
Top achievements
Rank 1
answered on 14 Jul 2015, 07:40 AM
Hi Konstantin, Is the WebAii is sill free to use or is this already completely merged with Telerik?
Asked by
Tyrone
Top achievements
Rank 1
Answers by
Konstantin Petkov
Telerik team
Tyrone
Top achievements
Rank 1
Christopher
Telerik team
Nikolai
Telerik team
Abhash
Top achievements
Rank 1
Share this question
or