This is a migrated thread and some comments may be shown as answers.

Load testing (Data Driven)using Test Studio

1 Answer 17 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Bipin
Top achievements
Rank 2
Bipin asked on 06 Jul 2017, 07:37 PM

Hi,

I am looking for any help regarding these issues which you might have encountered using Test Studio for Load testing.

  1. I am unable to use a previously created functional script ( even without data driven) as a load test script.- I do not see any traffic captured this way.
  2. Since (1) was not working for me, I tried doing a new capture option which within load test and then went along recording my script, even in this case I do not web traffic being captured.
  3. Since (1) and (2) are not working for me, I then download Fiddler Cap on the suggestion of a test studio support person and then tried using Fiddler Cap to get the web traffic, Since I am going after the https link, I selected

       a)Decrypt HTTPS traffic in fiddler cap

       b) In test studio project settings, Settings -> Others -> Connection Settings -> Register certificate for https connection. ( which tells me that I have now installed the certificate) 

In spite of the above two steps, when I start Fiddler Cap, I still get the "connection not secure" pop up on IE .I ignore that and go ahead and Fiddler Cap seems to capture the traffic, which I then import into Test Studio Load profile.

When I kick off the test, it looks like the test is running, but it is not, since when I check the Database, no new rows are created , when they should be and the data is untouched. So I know its not working.

Did any one have the same issues and were you able to resolve this?  Test studio has a proxy which kicks in during load testing to my knowledge, in that case , is there anything which might prevent the web traffic capture. I need a resolution to this asap and posting this here to see if any one of the users have experienced this.

Appreciate any help in this regard. I am new to test studio and trying to get past this issue.

Thank you.

1 Answer, 1 is accepted

Sort by
0
Elena
Telerik team
answered on 11 Jul 2017, 12:16 PM
Hi Bipin,

I am glad to know you are trying to get some further advice from anyone of the community and am interested to find out if there will be any further suggestions. 

Since I have shared all possible approaches to you already I suspect the issue is related to some environmental specifics. These will be verified and inspected during the suggested web session. 

Thus I am leaving the thread open in case there is anyone willing to share something on the topic. 

Thanks! 

Regards,
Elena Tsvetkova
Progress Telerik
 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Bipin
Top achievements
Rank 2
Answers by
Elena
Telerik team
Share this question
or