Coded UI not able to locate telerik Red Toggle Button

2 posts, 0 answers
  1. Prashannajit
    Prashannajit avatar
    1 posts
    Member since:
    May 2011

    Posted 30 May 2011 Link to this post

    I am using VSTS 2010 Coded UI for automated Test.

    While I am recording actions from our program window, telerik rad Toggle Button is recorded as win button but when I re run the script It throws below error.

    Microsoft.VisualStudio.TestTools.UITest.Extension.UITestControlNotFoundException: The playback failed to find the control with the given search properties. Additional Details:
    TechnologyName:  'MSAA'
    ControlType:  'Window'
    Name:  'Open'
    ClassName:  '#32770'

    I had also tries to locate the tab by manually searching for the control withing specific container but it throws the error that windows control could not find.

    I tries to resolve it every possible way to locate the control but VSTS 2010 Coded UI not able to locate the control.

    Please help me resolve the issue ASAP.
  2. Vladislav
    Admin
    Vladislav avatar
    277 posts

    Posted 31 May 2011 Link to this post

    Hello Prashannajit,

    Unfortunately our support for coded UI tests is currently quite limited.
    We are aware of this issue and have an improvement task for it in our plans.
    Currently I cannot commit to a specific date/time frame for this fix/improvement.

    Can I suggest you to try our Test Studio suite, which is developed specifically in order to test our Silverlight & WPF controls.

    All the best,
    Vladislav
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

Back to Top