Chrome run/calibrate error

4 posts, 0 answers
  1. Paripassu
    Paripassu avatar
    2 posts
    Member since:
    Aug 2017

    Posted 08 Sep 2017 Link to this post

    Hi,

    Whenever I try to either calibrate on run tests on Chrome I get an unexpected error.

    Here is the relevant log:

    [09/08 09:21:52,Telerik.TestStudio.Desktop.exe(3132:1)] First trace message from process 3132: "C:\Program Files (x86)\Telerik\Test Studio\Bin\Telerik.TestStudio.Desktop.exe" False "C:\Users\dalmaso\git\automacao-ui-clicq" /trial
    [09/08 09:21:52,Telerik.TestStudio.Desktop.exe(3132:1)] First trace message from foreground thread "Application start thread" (managed ID = 1, native ID = 21140).
    [09/08 09:21:52,Telerik.TestStudio.Desktop.exe(3132:1),TestStudio] TestExplorerController.ExecuteCommand() : EXCEPTION! (see below)
         Outer Exception Type: ArtOfTest.WebAii.Core.BrowserConfigurationException
         Message: All running browser instances must to be closed.
         HRESULT: 0x80131500 (Official ID (if app.) = COR_E_EXCEPTION, Error Bit = FAILED, Facility = FACILITY_URT, Code = 5376)
         Call Stack:
              em ArtOfTest.WebAii.Core.BrowserConfiguration.VerifyAllProcessesAreClosed(String processName)
              em ArtOfTest.WebAii.Core.BrowserConfiguration.EndRunningProcesses(String processName)
              em ArtOfTest.WebAii.Design.UI.RecordersController.PromptToCloseRunningBrowserInstances(String processName)
              em ArtOfTest.WebAii.Design.UI.TestExplorerController.ExecuteScenario(ExecutionType exeType, Boolean debuggerEnabled, IntPtr existingBrowserHandle, IList`1 selectedExecutionSteps, Boolean showBrowserSelection)
              em ArtOfTest.WebAii.Design.UI.TestExplorerController.ExecuteCommand(ICommand command, Object parameters)
     
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:33,Telerik.TestStudio.Desktop.exe(3132:1),Framework] FireFoxInstallation.EnumFireFoxInstallations() : Valid Firefox 55.0.0.3 (x86) installation found at "C:\Users\dalmaso\programas\firefox36\firefox.exe".
    [09/08 09:23:41,Telerik.TestStudio.Desktop.exe(3132:1),TestStudio] BrowsersViewModel.CalibrateBrowser() : EXCEPTION! (see below)
         Outer Exception Type: ArtOfTest.WebAii.Core.BrowserConfigurationException
         Message: All running browser instances must to be closed.
         HRESULT: 0x80131500 (Official ID (if app.) = COR_E_EXCEPTION, Error Bit = FAILED, Facility = FACILITY_URT, Code = 5376)
         Call Stack:
              em ArtOfTest.WebAii.Core.BrowserConfiguration.VerifyAllProcessesAreClosed(String processName)
              em ArtOfTest.WebAii.BrowserSpecialized.Chrome.ChromeConfiguration.ConfigureBrowser(String& error)
              em ArtOfTest.WebAii.Core.BrowserConfigurationUtils.ConfigureBrowser(BrowserType browser, String& error)
              em ArtOfTest.WebAii.Design.UI.BrowsersViewModel.CalibrateBrowser(BrowserType browser)

     

    We are currently trialing the product and it works fine for other colleagues and on EC2 Windows Server, but not for me. I have reinstalled both Chrome and Test Studio, not sure how to proceed next.

    Regards,

    Gustavo

  2. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    942 posts

    Posted 12 Sep 2017 Link to this post

    Hi Paripassu,

    Thank you the shared details. 

    Could you please let me know which is your current Test Studio version? The installed extensions are the latest which were released with our latest service pack edition. Have you installed that Service Pack 2017.2
    824? 

    If the product is up to date please let me know if there are any Chrome instances opened when you attempt to calibrate? If there are any please close these and then try again. What the result would be? 

    I am looking forward to hearing from you! Thank you! 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Paripassu
    Paripassu avatar
    2 posts
    Member since:
    Aug 2017

    Posted 12 Sep 2017 in reply to Elena Tsvetkova Link to this post

    Yes, it shows as Produtct Version 2017.2.824.0.

    No Chrome instances are opened when I attempt. I have tried to uninstall Chrome and delete all Chrome and Google data I found no AppData and ProgramData and then a new install, but the problem continues.

    Regards,

  4. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    942 posts

    Posted 14 Sep 2017 Link to this post

    Hello Paripassu,

    Thank you for getting back to me. 

    Could you please explicitly start Test Studio as administrator from the right mouse button context menu and give a try to record a test again or calibrate Chrome? Will the behavior be the same? 

    If there is no change please double check if there are some Chrome processes left in the Task Manager and if any kill these. Then attempt again to calibrate or record against Chrome. 

    If the above still does not change anything please let me know what is the OS of the machine in use. In case it is a server one and there is another user session, could it be so that this other session hosts some Chrome processes? 

    Please let me know your input on the above listed notes. I am looking forward to hearing from you! 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top