Can't Highlight Table Element

5 posts, 1 answers
  1. Alan
    Alan avatar
    15 posts
    Member since:
    Aug 2014

    Posted 14 Jan 2015 Link to this post

    In the latest release, version 2014.4.1211.0, I am trying to highlight a table on a page, but Test Studio is only allowing me to highlight the specific element where my cursor is positioned. I can no longer highlight a table row or the table itself. With the previous version of Test Studio, the element highlighting used the blue nubs to represent different levels of the page elements. For example, the first nub represents one of the data elements in a specific table row, the second nub represents the table row, the third nub represents all the data rows and the fourth nub represents the table itself, including all the data rows, heading row, and table name. If I wanted to verify the table was present on the page, I could select the fourth nub to select the table. The new version of Test Studio no longer uses the little blue nubs, but instead throws up a menu with options related to the specific element my cursor is positioned on. Test Studio seems to assume I want the most specific and narrow definition of whatever I have my cursor on. When I position the cursor on any of the table elements, I can get the quick tasks for that specific element only. I can't get the tasks for the table row and I can't get the tasks for the table itself.

    How would I highlight the whole table and not just a specific element in the table?
  2. Boyan Boev
    Admin
    Boyan Boev avatar
    1072 posts

    Posted 19 Jan 2015 Link to this post

    Hello Alan,

    It seems we have a bug in Test Studio and the translators are not displayed when the table is highlighted. 

    I have logged a bug report which you can track and vote for it here.

    Thank you for your feedback.

    Regards,
    Boyan Boev
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Answer
    Boyan Boev
    Admin
    Boyan Boev avatar
    1072 posts

    Posted 21 Jan 2015 Link to this post

    Hi Alan,

    After further debugging we have changed this bug report to a feature request since we have never had translators for pure HTML table. We have translators in IE for RadGrid table e.t.c.

    What kind of table do you use exactly? Could you please send us a screen shot of it and its DOM so we can investigate this further.

    Thank you for your cooperation.

    Regards,
    Boyan Boev
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  4. Alan
    Alan avatar
    15 posts
    Member since:
    Aug 2014

    Posted 22 Jan 2015 in reply to Boyan Boev Link to this post

    I talked to my developers and they typically use the Telerik controls in the sites/apps they develop. In this case, the site is still under development and they used the HTML elements to prototype the site, just to show what the site will look like before they had developed any functionality for the site. As they start developing more and more of the functionality of the site, they'll be using the Telerik controls.

    I've attached a screen shot of the table and the table's DOM and marking this thread as answered. I don't consider this to be high priority.
  5. Boyan Boev
    Admin
    Boyan Boev avatar
    1072 posts

    Posted 24 Jan 2015 Link to this post

    Hello Alan,

    If your developers use pure HTML elements only for the prototype of the site then this is expected behavior. As I mentioned we do not have such ability (translators) for a pure HTML table.

    However we will add it in the next internal build so you will be able to use it  even against HTML table.

    Thank you for you feedback and cooperation. 

    Regards,
    Boyan Boev
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top