13:53:21.594 [ERROR] Could not load file or assembly 'Telerik.ApiTesting.Framework, Version=2019.1.130.1044, Culture=neutral, PublicKeyToken=5a3105392

5 posts, 0 answers
  1. Yulia
    Yulia avatar
    3 posts
    Member since:
    Jun 2014

    Posted 29 Oct Link to this post

    Hi, After update Telerik to :Product version : 2019.3.1002.0

     

    Web API project stop to work , get runtime error: (compile is OK )

    13:53:21.594 [ERROR] Could not load file or assembly 'Telerik.ApiTesting.Framework, Version=2019.1.130.1044, Culture=neutral, PublicKeyToken=5a31053920bb0a73' or one of its dependencies. The system cannot find the file specified.

     

  2. Plamen Mitrev
    Admin
    Plamen Mitrev avatar
    133 posts

    Posted 29 Oct Link to this post

    Hello Yulia,

    You have submitted also a private ticket where we can discuss the issue in more details and exchange additional resources. In general this is a known issue with embedded API projects in your Test Studio project that have coded steps and happens after Test Studio update. We will be working towards resolving this in the future releases. 

    The workaround is to:

    - open the project root folder;
    - navigate to the "ApiTests" folder;
    - navigate to "bin" folder;
    - delete all files in the "bin" folder;
    - open the project in Test Studio and execute it again. As a result the assemblies for the embedded API project should be rebuilt with the correct Telerik.ApiTesting.Framework.dll version.

    I hope that this will work for you and anyone that encounters this issue before it is fixed.

    Thank you for your understanding in advance.

    Regards,
    Plamen Mitrev
    Progress Telerik

     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Yulia
    Yulia avatar
    3 posts
    Member since:
    Jun 2014

    Posted 30 Oct in reply to Plamen Mitrev Link to this post

    hello, I did all these steps , and it is didn't help !

    Please send me the required dll  zipped by email (use zip password  = 11111)

    Thanks

  4. Yulia
    Yulia avatar
    3 posts
    Member since:
    Jun 2014

    Posted 30 Oct Link to this post

    This issue is solved , there was a broken paths in a project . Thanks 
  5. Plamen Mitrev
    Admin
    Plamen Mitrev avatar
    133 posts

    Posted 30 Oct Link to this post

    Hello Yulia,

    Thank you for sharing more details about the cause for this issue. I understand that the project builds successfully on your end.

    Please feel free to contact us again, if you encounter any troubles.

    Regards,
    Plamen Mitrev
    Progress Telerik

     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top