This is a migrated thread and some comments may be shown as answers.

Why test list executes all deactivated test steps?

2 Answers 32 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Paul
Top achievements
Rank 1
Veteran
Paul asked on 17 Jun 2020, 08:11 AM

Good morning,

fFor test development i add tests for e.g. login and calling of the needed mask...then i deactivating these for further changes on this test.
This saves much time when i have to edit one of the tests - i set only two or three checkboxes and say "run to here" to continue editing or doing the change i need.

Now i testes a whole mask by adding the standard tests for login, logout and so on.
Test for adding fails, because this test hiere is calling all the deactivated steps.  But for what reason we have checkboxes for active-state of the test steps when these are overriden by test list execution?  This makes no sense for me.

As you can see in the screenshots step 6 is deactivated - but executed by test list.

I have several tests where i deactivated bigger IF-brunches for future testing. These will be executed by test list too, when i undestand this execution result.

Greetings
Paul

2 Answers, 1 is accepted

Sort by
0
Paul
Top achievements
Rank 1
Veteran
answered on 17 Jun 2020, 08:13 AM
Selected step 6 in test result = real (deactivated) step 7 in the "TTS_deactivated_tests.png"
0
Plamen Mitrev
Telerik team
answered on 18 Jun 2020, 06:56 AM

Hello Paul,

I analyzed the attach details and noticed that the test "Maschine_MASKE" is partially executed. It has a If...Else condition, which will always show up the green "play" icon in column "More" (see moreColumn.png), but is is not actually executed and there are no results showing in the column "Result".

I prepared a sample test, which has If...Else conditions and I ran it as part of a test list locally 2 times. Once with the If...Else disabled and another time - enabled. This produced different results, as you can see in the attached files, and they are as you would expect. The first time there are no steps from the If...Else that are executed and the second time they were successfully executed. Please explore the attached test and result files and run it also on your end.

Please help me investigate this further, by sharing more details on the topics below.

  • Create and attach a sample Test Studio project against a publicly accessible application, that I can run and reproduce the misbehavior.
  • Please share the .aiiresult file of the local test list execution in a .zip format. It should be located in the project's root folder, under Results subfolder.
  • Do you use a scheduling setup to execute the test lists remotely, you run them locally on your machine from the Run List button? if you are using a scheduling server, please share more details about the setup you have (single machine or multiple machine setup) and take a screenshot of the Execution Status.

I am looking forward to hearing from you and continue our discussion.

Regards,
Plamen Mitrev
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Tags
General Discussions
Asked by
Paul
Top achievements
Rank 1
Veteran
Answers by
Paul
Top achievements
Rank 1
Veteran
Plamen Mitrev
Telerik team
Share this question
or