VS2015 Test Explorer does not show tests

3 posts, 0 answers
  1. Phillip
    Phillip avatar
    2 posts
    Member since:
    Apr 2018

    Posted 09 Apr Link to this post

         Hi All,

    I currently have test project where it has feature file that has 30 test scenarios.  it had been working which mean I could run the test and see the test showing up in Test Explorer, not until I made mistake to delete content in this folder "AppData\Local\Microsoft\VisualStudio\14.0\Extensions" because I thought I was deleting something from this folder "AppData\Local\Temp\VisualStudioTestExplorerExtensions"  as a result it messed up my test project.  So I started troubleshooting, suddenly all of my tests stop showing up in the Test Explorer.

    My project installations has: NUnitTestAdapter, SpecFlow, SpecFlow.Assit.Dynamic, SpecRun.Runner, Selenium.Support, Selenium.WebDriver, NUnit, Selenium.StandardControls.

    My Visual Studio is Community 2015.

    Also I purchased SpecRun license as well.

  2. Ivaylo
    Admin
    Ivaylo avatar
    775 posts

    Posted 12 Apr Link to this post

    Hello Phillip,

    Make sure you have Visual Studio closed, uninstall Test Studio and install it from scratch. This should install the extension and you should be able to see the tests in the Test Explorer again.

    Regards,
    Ivaylo
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Phillip
    Phillip avatar
    2 posts
    Member since:
    Apr 2018

    Posted 12 Apr in reply to Ivaylo Link to this post

    Hi, thank you for replying back.

    In my visual studio 2015, I go to Tools -> Extensions and Updates, but I don't see any Test Studio package or app showing. My test is using SpecFlow with Visual Studio 2015.  I don't recall I installed any Test Studio though.  Am I not looking at the correct place for Test Studio?  thanks.

Back to Top