This is a migrated thread and some comments may be shown as answers.

User Profile Capturing

9 Answers 97 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Josh
Top achievements
Rank 1
Josh asked on 05 Apr 2013, 02:37 AM
I can't seem to capture any user data for load testing using the inbuilt Capture feature (Telerik Test Studio v2012.2.1420.0).

Everything is hosted locally on the controller/recorder. This local machine is also the only agent. You may cringe but this is for proof-of-concept more than anything. The application I'm testing uses HTTPS.

I tried to capture data using "Capture New" in IE. Fiddler2 was picking up all the HTTPS traffic but no results in Telerik. The "User Traffic" pane in the "Edit User Profile" window remained completely blank no matter how long I waited. Got the same results in Chrome and Firefox.

9 Answers, 1 is accepted

Sort by
0
Boyan Boev
Telerik team
answered on 08 Apr 2013, 08:41 AM
Hi Josh,

I am sorry to hear you are running into this problem.

It seems you have not configured the Load Services.  Please start up the "Configure Load Services" application from Start > All Programs > Telerik > Test Execution > Configure Load Test Services and configure them according this article.

Make sure all the Load testing related service are running.

Note that you should run Test Studio as administrator.

Please record a Jing video demonstrating the entire process, so we can better understand what is happening. 

Here is a video which is showing the entire process.


Let me know if this helps.

Greetings,
Boyan Boev
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Josh
Top achievements
Rank 1
answered on 08 Apr 2013, 09:16 PM
I have actually configured everything according to the instructions. Here is the video you requested.
0
Boyan Boev
Telerik team
answered on 09 Apr 2013, 04:00 PM
Hello Josh,

Thank you for the video.

It seems that something interferes with our proxy. We run our proxy in order to intercept and record the HTTP traffic.

Do you use some IE proxy? If so please set IE to NOT use any proxy in normal use, and to  NOT have the "automatically detect" setting checked (see the attached screen shot). 

You can also turn off the firewall and give it a try.

Hope this helps.

Greetings,
Boyan Boev
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Josh
Top achievements
Rank 1
answered on 11 Apr 2013, 08:50 PM
The proxy settings are all already as required on all browsers and the firewall is also turned off (it causes conflicts in certain networking tasks). This is becoming quite a large issue and an especially strange one as Fiddler has no problems picking up traffic.

What proxy settings does Test Studio use? I might have a look at the proxy settings when I start up the traffic capturer and see if Test Studio is "injecting" the right settings.
0
Cody
Telerik team
answered on 11 Apr 2013, 09:23 PM
Hi Josh,

Test Studio uses Fiddler Core for its HTTP proxy. It is very concerning to us that the full Fiddler application works but our HTTP Proxy doesn't since the two are effectively using the same technology.

I'd like to look at this problem on your computer via GoToMeeting. Let me know what time zone you are in and your availability and I'll setup the meeting. I'm in Austin, TX which is Central Time (GMT -6).

Regards,
Cody
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Josh
Top achievements
Rank 1
answered on 11 Apr 2013, 10:45 PM
I'm not able to use GoToMeeting - any alternative you can think of?

I already have a phone meeting scheduled with Ramiro Milan, your colleague in Boston, in just over 2 hours. It's possible that he will be able to help me. Perhaps the two of you can collaborate on this?
0
Cody
Telerik team
answered on 12 Apr 2013, 02:24 PM
Hi Josh,

I heard through Cameron that you are located in New Zealand. This presents a little bit of a challenge due to the great time difference between us. But it looks like my 4pm is your 9am and my Monday (your Tuesday morning) would be the next available time.

I've only used Skype a couple of times, and only for voice, so I'm not very used to it. Can it do screen sharing? It will be important for me to be able to see your screen in this meeting. You are in my calendar for 4pm Monday (Austin, TX time zone).

Kind regards,
Cody
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Josh
Top achievements
Rank 1
answered on 12 Apr 2013, 10:57 PM
9am Tuesday my time works for me.

Yes, you can screen share in Skype so that shouldn't be a problem. So that sounds like a plan!
0
Cody
Telerik team
answered on 18 Apr 2013, 02:24 PM
Hello Josh,

(I'm late updating this ticket with a summary of our meeting.)

What we found during our meeting is that your machine is using Trend Micro for anti-virus control. This product inserts itself as a HTTP proxy forcing all HTTP communication to run through it. As a result when we try to record a new load test, Test Studio sees that all HTTP traffic is coming from the TMPROXY.EXE process instead of IEXPLORE.EXE. Since Test Studio filters on IEXPLORE.EXE it's deliberately dropping all of the TMPROXY traffic which actually contains the browser traffic we need. The end result is that Test Studio won't record any traffic in the user profile. I've filed a bug on this here. Hopefully we can figure out a way to be compatible with Trend Micro in the future.

Greetings,
Cody
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
Tags
General Discussions
Asked by
Josh
Top achievements
Rank 1
Answers by
Boyan Boev
Telerik team
Josh
Top achievements
Rank 1
Cody
Telerik team
Share this question
or