Updated Telerik controls cause test failure

4 posts, 0 answers
  1. Helen
    Helen avatar
    15 posts
    Member since:
    Sep 2010

    Posted 08 Dec 2011 Link to this post

    Hi
    We are using Telerik controls all over in our application and we use Test Studio for automated testing.
    We updated the controls to a newer version and now all our tests fail on verify/wait for steps for various objects(windows, comboboxes, etc)

    Is there any way to update/patch all tests to look for new controls for those steps?

    One more question - I use the same test set for several environments that currently use different versions of controls. Is there a way to customize the controls version for all of them?

    Thanks a lot!
    Helen
  2. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 11 Dec 2011 Link to this post

    Hi Helen,

    Thank you for contacting us!

    Whenever RadControl changes our team updates the respective RadControls Translators to ensure compatibility as well. Thus to avoid any issues automating the latest RadControls (Silverlight, AJAX or WPF) please also upgrade to the latest Test Studio build too (the latest official build has been released a couple of weeks ago and we also published an internal build last week).

    Please let us know should you need further assistance.

    Best wishes,
    Konstantin Petkov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Helen
    Helen avatar
    2 posts
    Member since:
    Oct 2010

    Posted 03 Jan 2012 Link to this post

    Hi Konstantin

    I upgraded Test Studio to version 2011.2.1117.0, but all my tests still fail on "radwindow(Wait for): is open" steps and also fail on finding window scrolling elements, etc
    I wonder what could cause it?

    Thanks in advance
    Helen
  4. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 04 Jan 2012 Link to this post

    Hi Helen,

    We're not aware of any problem like this so will need to look into the exact case to troubleshoot the problem. Please submit a support ticket and send us a problematic test to look at locally. I hope you can send a runnable scripts so that we can isolate the issue and get back to you with our findings.

    Greetings,
    Konstantin Petkov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top