Unable to find test as step in remote execution

3 posts, 0 answers
  1. Jin Khai
    Jin Khai avatar
    11 posts
    Member since:
    Mar 2018

    Posted 07 Apr Link to this post

    I am evaluating this software now,

    My Web System.tstest is part of the shared test in another test.

    It works OK when i run locally, but when i run remotely using scheduling services and another test runner, then prompt this error.

    InnerException:

    System.IO.FileNotFoundException: Unable to find test 'Login & Logout\My Web System.tstest'
       at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteTestInCurrentContext(String relativeTestPath)
       at ArtOfTest.WebAii.Design.IntrinsicTranslators.Descriptors.ExecuteTestActionDescriptor.Execute(IAutomationHost autoHost, TestAsStepResult result)
       at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)
    ------------------------------------------------------------
    '4/7/2018 7:49:56 AM' - Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution.
    ------------------------------------------------------------
    '4/7/2018 7:49:56 AM' - Overall Result: Fail
    '4/7/2018 7:49:56 AM' - Duration: [0 min: 2 sec: 361 msec]
    ------------------------------------------------------------
    '4/7/2018 7:49:56 AM' - Test completed!

     

     

     

  2. Jin Khai
    Jin Khai avatar
    11 posts
    Member since:
    Mar 2018

    Posted 07 Apr in reply to Jin Khai Link to this post

    I found some workaround, I was moving this share tests to a folder, and it works OK on local, but when run on remote then start to give problem. So the workaround is move back the tests back to root instead. I moved the test file using the Test Studio (not at window explorer).

    But why it failed with just a simple file move?

  3. Daniel Djambov
    Admin
    Daniel Djambov avatar
    74 posts

    Posted 12 Apr Link to this post

    Hi Jin,

    You should not have problems when moving tests that are used as test as steps in other tests if you do it using Test Studio interface. If you move files using Windows Explorer, the connection parent to child (used as test as step) test breaks.

    Here is some info how Test Studio updates files in remote execution, which can help you understand why it doesn't always work at your end.

    When you create a scheduled remote run first time, project files and tests in the test list, including tests used as tests as steps are uploaded to MongoDB database, from where they are downloaded during scheduled execution by the Execution Servers. So if you create a remote scheduled run, all files get uploaded to the MongoDB. If you then move or make changes to any of these tests, after saving them, if you trigger another remote run, we check if the files already uploaded into the DB are older than existing ones and re-upload the changed files. What you describe can happen if the parent test is not changed for some reason, but child test is changed and  it does not get re-uploaded to db, so it fails to find it upon execution, which can happen only if tests are copy/pasted/moved using windows explorer as per our knowledge.

    What I can advise you is to drop the MongoDB and create a new run, this will upload all needed files properly.

    If you face similar issue again, please let us know exactly what you did in project like copy/paste/move of tests before the problem occurs.

    Thank you for your feedback and cooperation.

    Best Regards,
    Daniel Djambov
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top