This is a migrated thread and some comments may be shown as answers.

unable to enter text in auto complete text box using test studio

11 Answers 163 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
kiran
Top achievements
Rank 1
kiran asked on 05 May 2011, 10:50 AM
Hi,
I am new to telerik web studio,
I am working on silverlight web application,
we have a silverlight autocomplete text box[language] at registration form in our application,
recorded text "English" [typed] in auto complete text box unable to placing at run time.

please check it
Log:
[4:47 PM] - LogMessage: [4:47:13 PM] - Test Studio (version:2011.1.502.0) started.
    ======  ======
    Title: Initiate log
    Message:
    Title: Initiate InternalManager
    Message: Trying to Validate License
    Title: Requesting EVT
    Message: EVTP
    Title: Requesting Validation
    Message: ILMValidate
    Title: ILMValidate action
    Message: Set PC
    Title: ILMValidate action
    Message: Check for VL
    Title: LICENSER
    Message: TRL MODE
    Title: LICENSER
    Message: DS LEFT28
    Title: LICENSER
    Message: DT MARK PASSED28.00:00:00
    Title: ILMValidate action
    Message: ITM TRUE
    Title: MLW action
    Message: MLW  CNSTR: True
    Title: MLW action
    Message: MLW  IC SUCCESS
    Title: MLW action
    Message: MLW LITS REQ
    Title: MLW action
    Message: MLW LITS REQ SUCCESS
    Title: ILMValidate action
    Message: ITM SHD
    Title: ILMValidate action
    Message: ITM TRUE
    Title: Requesting Validation
    Message: ILMValidate True
    Title: Requesting Validation
    Message: ILMValidate True Trial
    [4:47 PM] - LogMessage: [4:47:21 PM] - Active Project is : 'TestProject2'
    [4:47 PM] - LogMessage: [4:47:21 PM] - Project 'TestProject2' Ready.
    [4:47 PM] - Error loading referenced assembly ArtOfTest.Common, Version=2010.3.1213.0, Culture=neutral, PublicKeyToken=14a0200bfcbb7b62
    [4:47 PM] - LogMessage: [4:47:29 PM] - Test 'Login' selected.
    [4:48 PM] - LogMessage: [4:48:27 PM] - Test 'Login' selected.
    [4:49 PM] - LogMessage: [4:49:18 PM] - Loading '1' results..
    [4:49 PM] - LogMessage: [4:49:18 PM] - Results are loaded!
    [4:49 PM] - LogMessage: [4:49:39 PM] - Test 'Login' selected.
    [4:50 PM] - LogMessage: [4:50:31 PM] - Test 'Login' selected.

regards

kiran

11 Answers, 1 is accepted

Sort by
0
Konstantin Petkov
Telerik team
answered on 05 May 2011, 11:15 AM
Hello kiran,

Thank you for contacting us.

Is this the 2011.1 version (labeled 1502) that you get the problem with? Can you please attach the complete test log for us to look at?

Kind regards,
Konstantin Petkov
the Telerik team
Do you think you know all the new features coming out in Test Studio R1 2011? Think again - we have some surprises and will share them with you in the What's New in Test Studio R1 2011 Webinar on May 12th.
Register Today!
0
kiran
Top achievements
Rank 1
answered on 05 May 2011, 12:31 PM
please check it,
Log:
[4:47 PM] - LogMessage: [4:47:13 PM] - Test Studio (version:2011.1.502.0) started.
    ======  ======
    Title: Initiate log
    Message:
    Title: Initiate InternalManager
    Message: Trying to Validate License
    Title: Requesting EVT
    Message: EVTP
    Title: Requesting Validation
    Message: ILMValidate
    Title: ILMValidate action
    Message: Set PC
    Title: ILMValidate action
    Message: Check for VL
    Title: LICENSER
    Message: TRL MODE
    Title: LICENSER
    Message: DS LEFT28
    Title: LICENSER
    Message: DT MARK PASSED28.00:00:00
    Title: ILMValidate action
    Message: ITM TRUE
    Title: MLW action
    Message: MLW  CNSTR: True
    Title: MLW action
    Message: MLW  IC SUCCESS
    Title: MLW action
    Message: MLW LITS REQ
    Title: MLW action
    Message: MLW LITS REQ SUCCESS
    Title: ILMValidate action
    Message: ITM SHD
    Title: ILMValidate action
    Message: ITM TRUE
    Title: Requesting Validation
    Message: ILMValidate True
    Title: Requesting Validation
    Message: ILMValidate True Trial
    [4:47 PM] - LogMessage: [4:47:21 PM] - Active Project is : 'TestProject2'
    [4:47 PM] - LogMessage: [4:47:21 PM] - Project 'TestProject2' Ready.
    [4:47 PM] - Error loading referenced assembly ArtOfTest.Common, Version=2010.3.1213.0, Culture=neutral, PublicKeyToken=14a0200bfcbb7b62
    [4:47 PM] - LogMessage: [4:47:29 PM] - Test 'Login' selected.
    [4:48 PM] - LogMessage: [4:48:27 PM] - Test 'Login' selected.
    [4:49 PM] - LogMessage: [4:49:18 PM] - Loading '1' results..
    [4:49 PM] - LogMessage: [4:49:18 PM] - Results are loaded!
    [4:49 PM] - LogMessage: [4:49:39 PM] - Test 'Login' selected.
    [4:50 PM] - LogMessage: [4:50:31 PM] - Test 'Login' selected.

0
Konstantin Petkov
Telerik team
answered on 06 May 2011, 08:26 AM
Hello kiran,

I actually meant the test log, not the project one. When you execute a test from the Record View just look for a "Log" link button at the very right in the summary above the test steps list (find a screen shot attached). Click on it to open the text viewer and copy the log to the clipboard then paste it in the ticket. Thank you!

Kind regards,
Konstantin Petkov
the Telerik team
Do you think you know all the new features coming out in Test Studio R1 2011? Think again - we have some surprises and will share them with you in the What's New in Test Studio R1 2011 Webinar on May 12th.
Register Today!
0
kiran
Top achievements
Rank 1
answered on 06 May 2011, 10:57 AM

Hi Konstantin Petkov,

Sorry i couldn't get u earlier, please check it now

Overall Result: Fail
------------------------------------------------------------
'5/6/2011 3:19:16 PM' - Starting execution....
'5/6/2011 3:19:16 PM' - Detected a Silverlight Test. Setting EnableSilverlight=True
------------------------------------------------------------
------------------------------------------------------------
'5/6/2011 3:19:19 PM' - Detected DataDriven Test. Starting data iterations.
------------------------------------------------------------
------------------------------------------------------------
Overall Result: Fail
'5/6/2011 3:19:29 PM' - 'Pass' : 2. radmaskedtextbox: click with '1' offset action.
'5/6/2011 3:19:30 PM' - 'Pass' : 3. radmaskedtextbox: type 'test' text action. - DataDriven: [$(Uname)]
'5/6/2011 3:19:31 PM' - 'Pass' : 4. LeftClick on Item1Textboxview
'5/6/2011 3:19:32 PM' - 'Pass' : 5. Type 'test' into TxtPasswordPasswordbox - DataDriven: [$(pswd)]
'5/6/2011 3:19:32 PM' - 'Pass' : 6. LeftClick on Item2Textboxview
'5/6/2011 3:19:32 PM' - 'Pass' : 7. radnumericupdown: Type '2' into TextboxPickertextbox - DataDriven: [$(Lid)]
'5/6/2011 3:19:32 PM' - 'Pass' : 8. Click LoginButtonRadbutton
'5/6/2011 3:19:32 PM' - 'Pass' : 9. Wait for '250' msec.
'5/6/2011 3:19:33 PM' - 'Pass' : 10. Wait for '250' msec.
'5/6/2011 3:19:42 PM' - 'Pass' : 11. radtabitem: item 'Patient' select action.
'5/6/2011 3:19:42 PM' - 'Pass' : 12. LeftClick on PatientsRadribbontogglebutton
'5/6/2011 3:19:53 PM' - 'Pass' : 13. gridviewrow (Wait for): row index 'Equal' '9'.
'5/6/2011 3:19:54 PM' - 'Pass' : 14. Click BtnAddRadbutton
'5/6/2011 3:19:55 PM' - 'Pass' : 15. LeftClick on Item1Textboxview
'5/6/2011 3:19:56 PM' - 'Pass' : 16. Type 'krishna123' into TxtUserNameTextbox
'5/6/2011 3:19:57 PM' - 'Pass' : 17. LeftClick on Item2Textboxview
'5/6/2011 3:19:58 PM' - 'Pass' : 18. Type 'medwrite' into TxtPwdPasswordbox
'5/6/2011 3:19:58 PM' - 'Pass' : 19. LeftClick on Item3Textboxview
'5/6/2011 3:19:59 PM' - 'Pass' : 20. Type 'medwrite' into TxCPwdPasswordbox
'5/6/2011 3:19:59 PM' - 'Pass' : 21. Click EnterRadbutton
'5/6/2011 3:20:02 PM' - 'Pass' : 22. LeftClick on Item5Textboxview
'5/6/2011 3:20:03 PM' - 'Pass' : 23. Type 'plname' into TxtPLastnameWatermarkedtextbox
'5/6/2011 3:20:03 PM' - 'Pass' : 24. LeftClick on Item6Textboxview
'5/6/2011 3:20:04 PM' - 'Pass' : 25. Type 'pfname' into TxtPFirstnameWatermarkedtextbox
'5/6/2011 3:20:04 PM' - 'Pass' : 26. LeftClick on Item8Textboxview
'5/6/2011 3:20:05 PM' - 'Pass' : 27. raddatepicker: Type '6/6/1986' into PARTDateTimeInputRadwatermarktextbox
'5/6/2011 3:20:05 PM' - 'Pass' : 28. Desktop command: LeftClick on PARTDropDownButtonRaddropdownbutton
'5/6/2011 3:20:07 PM' - 'Pass' : 29. Desktop command: LeftClick on ContentTextTextblock
'5/6/2011 3:20:07 PM' - 'Pass' : 30. Desktop command: LeftClick on PARTDropDownButtonRadtogglebutton
'5/6/2011 3:20:09 PM' - 'Pass' : 31. Desktop command: LeftClick on OutPatientRadcomboboxitem
'5/6/2011 3:20:09 PM' - 'Pass' : 32. Desktop command: LeftClick on PARTDropDownButtonRadtogglebutton0
'5/6/2011 3:20:10 PM' - 'Pass' : 33. Desktop command: LeftClick on MaleRadcomboboxitem
'5/6/2011 3:20:11 PM' - 'Pass' : 34. LeftClick on Item15Textboxview
'5/6/2011 3:20:12 PM' - 'Pass' : 35. Type '32 test' into TxtPAddress1Textbox
'5/6/2011 3:20:12 PM' - 'Pass' : 36. Wait for Exists 'AcbPZipNumericautocompletebox'
'5/6/2011 3:20:12 PM' - 'Pass' : 37. Verify AcbPZipNumericautocompletebox's text content Same ''
'5/6/2011 3:20:13 PM' - 'Pass' : 38. Desktop command: LeftClick on TextTextbox
'5/6/2011 3:20:13 PM' - 'Pass' : 39. Type '10001' into TextTextbox [It's an autocomplete box]
'5/6/2011 3:20:25 PM' - 'Fail' : 40. LeftClick on x10001Listboxitem
------------------------------------------------------------
Failure Information:
~~~~~~~~~~~~~~~
Unable to locate element. Details: Attempting to find [Silverlight] element using
Find logic
 (Html): [id 'Exact' silverlightControlHost] AND [tagname 'Exact' div][tagname 'Exact' object]
 (Silverlight): [automationid 'Exact' Selector] AND [XamlTag 'Exact' listbox] THEN UNDER NODE FIND [XamlPath 'Exact' /grid[0]/border[0]/scrollviewer[automationid=ScrollViewer]/border[0]/grid[0]/scrollcontentpresenter[name=ScrollContentPresenter]/itemspresenter[0]/virtualizingstackpanel[0]][VirtualizedIndex 'Exact' 0]

Unable to locate element. Search failed!

------------------------------------------------------------
'5/6/2011 3:20:25 PM' - Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution.
------------------------------------------------------------
'5/6/2011 3:20:25 PM' - Overall Result: Fail
'5/6/2011 3:20:25 PM' - Duration: [1 min: 6 sec: 2 msec]
------------------------------------------------------------
------------------------------------------------------------
'5/6/2011 3:20:25 PM' - Overall Result: Fail
'5/6/2011 3:20:25 PM' - Duration: [1 min: 6 sec: 9 msec]
------------------------------------------------------------
'5/6/2011 3:20:27 PM' - Test completed!


In the recording mode when ever entering text in that field it's recognizing as "TextBox" instead of "autocomplete box"

 

0
Konstantin Petkov
Telerik team
answered on 06 May 2011, 11:29 AM
Hi kiran,

Thanks for sending the log.

So the test fails when it looks for the auto complete box item to select. It looks like it has also failed to record the action correctly -- it is expected to record the select action from the AutoCompleteBox translator for Test Studio. The test step description should look like:

Select by index '0' in 'MyAutoCompleteBox'

Please find attached a test case I just recorded against an AutoCompleteBox live site. Please let me know it it works for you too.

BTW, do you get that select step always recorded as in your current test? Can you try recording it again please?

Kind regards,
Konstantin Petkov
the Telerik team
Do you think you know all the new features coming out in Test Studio R1 2011? Think again - we have some surprises and will share them with you in the What's New in Test Studio R1 2011 Webinar on May 12th.
Register Today!
0
kiran
Top achievements
Rank 1
answered on 06 May 2011, 12:38 PM
Hi Konstantin Petkov


i am unable to enter text in autocomplete box with listbox as a datatemplate for autocomplete box in radwindow how to find it
0
Konstantin Petkov
Telerik team
answered on 06 May 2011, 12:55 PM
Hello kiran,

It won't be easy to suggest a solution without having the exact scenario running. I just noticed this site is public though so we can help you automate it.

Please send us the test (.tstest|.aii + .resx and code behind if any) and we will get back to you with our findings. Thanks!

All the best,
Konstantin Petkov
the Telerik team
Do you think you know all the new features coming out in Test Studio R1 2011? Think again - we have some surprises and will share them with you in the What's New in Test Studio R1 2011 Webinar on May 12th.
Register Today!
0
kiran
Top achievements
Rank 1
answered on 06 May 2011, 02:06 PM
Hi,
I am sending screen shots, where exactly i am getting problem,
our developer told that they are using Autocomplete box with list box.

Screen one: Pointed Autocompleted text box
Screen Two: Highlighted Autocompleted text box with hover
Screen Three: After text entered in Autocompleted text box, i am getting list box
Screen Four: Highlighted list box with hover

Recording mode: Type '10001' into TextTextbox 
                               LeftClick on x10001Listboxitem

Execution mode[Run]: recorded text[10001] not presenting at text field at runtime, so list box not getting, so iam getting error.

regards

kiran

0
Dobry Zranchev
Telerik team
answered on 10 May 2011, 03:18 PM
Hi kiran,

Thank you for the screen-shots.

Unfortunately, I am not manage to reproduce the issue. I kindly ask you to prepare a test to some public data that reproduce that issue. It will be nice if you send all related files to the new created test. Meanwhile, probably this issue is not exist in the latest version, but we want to be sure that this is fixed. If you send this test we will be able to execute it on our site and to share the results with you. I am looking forward for your reply.

All the best,
Dobry Zranchev
the Telerik team
Do you think you know all the new features coming out in Test Studio R1 2011? Think again - we have some surprises and will share them with you in the What's New in Test Studio R1 2011 Webinar on May 12th.
Register Today!
0
Pankaj
Top achievements
Rank 1
answered on 05 Sep 2018, 01:09 PM

Hi Dobry, 

I am new to telerik and facing some issue.

I have to get the value which is given in auto-complete box after providing the text into it. for e.g if i provide "United" in autocomplete box then how to pick this value from auto-complete input box.

Could you please let me know how to achieve this in telerik test studio ?

 

 

0
Elena
Telerik team
answered on 10 Sep 2018, 02:57 PM
Hello Pankaj,

Thank you for reaching us out. 

As of the shared description I guess an extracted variable will suit your scenario. Once the dropdown value is selected you could extract it to a variable and then use it later in the test. The same could be accomplished in code depending on the solution you have chosen. 

I hope this will be useful for you. If further assistance is required please let me know further details for the scenario you need to cover. Thanks in advance!

Regards,
Elena Tsvetkova
Progress Telerik
 
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
 
Tags
General Discussions
Asked by
kiran
Top achievements
Rank 1
Answers by
Konstantin Petkov
Telerik team
kiran
Top achievements
Rank 1
Dobry Zranchev
Telerik team
Pankaj
Top achievements
Rank 1
Elena
Telerik team
Share this question
or