Trouble automating a RadAutoCompleteBox

2 posts, 0 answers
  1. Nick
    Nick avatar
    23 posts
    Member since:
    Nov 2013

    Posted 05 Dec 2014 Link to this post

    We've added a RadAutoCompleteBox to a control which handles email addresses and suggests those which have already been used.  I need to click in the box, and begin typing a few characters of a name, then verify the autocomplete suggested values are displaying what I want, and either continue typing or select a value.  The trouble I'm having is that once I get the automation to stop entering text, the control assumes that I'm done adding the value so it completes the entry and doesn't show me the suggested values.  This prevents me from accessing the items in the RadListBox/autocomplete results.

    I've tried different flavors of this so far without any luck (using Test Studio 2014.1.410):

    //Attempt 1
    //At this point "Test" is typed into the box, but then focus is lost so the autocomplete box doesn't display, it just assumes "Test" is all that was needed to be entered and I get an error attempting to click the RadListBox

    //Attempt 2
    //Same result as above, focus is lost after entering "Test" so the autocomplete box never opens and I get an error attempting to click the RadListBox

    //Attempt 3
    //Recorded Step: Click in the RadAutoCompleteBox
    //Recorded Step: Type "Test" into the box
    //Recorded Step: Select the first entry in the RadListBox
    //These steps will click in the box, enter the text, but once again not recognize the RadListBox autocomplete results

    Any other suggestions as to how I can approach this?  

  2. Cody
    Cody avatar
    3354 posts

    Posted 10 Dec 2014 Link to this post

    Hi Nick,

    In Attempt 1 you state "but then focus is lost so the autocomplete box doesn't display". This sounds like maybe the click happened at the wrong coordinates. Can you verify the mouse is moving to the right coordinates before it clicks? If <RadListBox>.Items[0] gives us incorrect coordinates this problem can happen.

    Attempt 2 sounds like it may be the same problem as attempt 1.

    In attempt 3, is SimulateRealTyping checked for the Type "Test" into the box step? This is very important for autocomplete controls.

    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top