This is a migrated thread and some comments may be shown as answers.

Test Studio Error when Launching Application

4 Answers 70 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Some
Top achievements
Rank 1
Some asked on 18 Oct 2011, 10:46 PM
Hello,
I am hoping to help a coworker resolve an error they have begun to receive when launching Test Studio.  It occurs just after launching the application the splash page is still up and it says "Save Project On Error".  An unexpected Error occured in Test Studio.  The error has been reported to the Telerik team.  Do you want to save your work?

This issue is affecting only a single account when launching the application when logged in under another account it works fine.  Any help is appreciated.

Thanks

4 Answers, 1 is accepted

Sort by
0
Anthony
Telerik team
answered on 18 Oct 2011, 10:58 PM
Hello Some,

We investigated this particular problem and found that somehow the TestStudioSettings.xml file can get damaged, which will cause your Test Studio application to not start.

The work-around is to find the file located in the following directory and delete it:

C:\Users\[user name]\AppData\Roaming\ArtOfTest\TestStudioSettings.xml

Upon launch, Test Studio will generate a new file with default values in it.

The permanent fix for the issue is implemented in our current internal build, version 2011.2.1007. To resolve this issue, either perform the above work-around or upgrade to the latest internal build.

Kind regards,
Anthony
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
AZ
Top achievements
Rank 1
answered on 27 Jan 2014, 03:21 PM
Hi,

i'm getting the same issue when i try to open Telerik "an unpected error occurred in Test Studio, the error has been reported to the Telerik Team".

I was unable to find the damaged file mentioned in your last post. I was unable to find it in my C: Drive under the path mentioned.
0
Danamma
Top achievements
Rank 1
answered on 30 Jan 2014, 09:37 AM
Hi,

I am getting the same issue when i try to launch Telerik (build no 2013.2)"an unexpected error occurred in Test studio,the error has been reported to the Telerik Team"

I deleted the file from above mentioned path C:\Users\[user name]\AppData\Roaming\ArtOfTest\TestStudioSettings.xml ,still facing same issue.

Please suggest me for further using Telerik  automation tool

0
Ivaylo
Telerik team
answered on 30 Jan 2014, 11:53 AM
Hello,

The workaround provided in this thread is very likely not to work since this is a forum post from 2011 which is almost 3 years ago. Please make sure you have the latest Test Studio version installed. 
You can use this download link in order to proceed. 
Please make sure you uninstall the Test Studio completely from your system. Before you install the latest version please delete the following folders:

C:\Program Files (x86)\Telerik
and
C:\ProgramData\Telerik

Perform with brand new installation.

You should no longer experience the problem described.

Regards,
Ivaylo
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Some
Top achievements
Rank 1
Answers by
Anthony
Telerik team
AZ
Top achievements
Rank 1
Danamma
Top achievements
Rank 1
Ivaylo
Telerik team
Share this question
or