Test list execution results not loading

2 posts, 1 answers
  1. Padmashree
    Padmashree avatar
    39 posts
    Member since:
    May 2018

    Posted 25 Feb Link to this post

    Hello,

    Test lists executed on-demand or scheduled are not loading to view results. On-demand and Scheduled execution on local and remote VM was working fine before though . I checked Scheduling service and Storage services are running. 

    When Run List remotely is kick off , am not seeing any test execution in action. I see get test results (Yellow Calendar) but unable to load results.

    I just have simple login script added to test list to test this out. This is what I see in the log file.

     

    [02/25 10:43:26,Telerik.TestStudio.Desktop.exe(7300:17),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function Start -------

    [02/25 10:43:26,Telerik.TestStudio.Desktop.exe(7300:42)] First trace message from pool unnamed thread (managed ID = 42, native ID = 9708).
    [02/25 10:43:26,Telerik.TestStudio.Desktop.exe(7300:42),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function End -------

    Thanks,

    -

    Padmashree

     

     

     

  2. Answer
    Elena
    Admin
    Elena avatar
    1104 posts

    Posted 28 Feb Link to this post

    Hello Padmashree,

    Thank you for sharing details on the encountered misbehavior. I suspect that any of the components in the Scheduling setup is stuck for some reason. To fix this you can restart the setup following the below steps: 
    - Open Manage Results in the Results Tab and delete any entries without End time.
    - Exit any Test Studio instances on all machines.
    - Restart the Telerik Services on the machine which hosts these.
    - Open Test Studio (or the Run-time) on the machine which hosts the Telerik Services and clear/enable the application log. These can be accessed via the Execution status view as well.
    - Open the Scheduling setup wizard and click on Apply for each tab.
    - Start the Execution server(s).
    - Verify if the remote machine(s) is(are) visible and active in the execution status. Enable/clear its log if still necessary.
    - Try to run a test list remotely and scheduled on the same machine.

    In case the above does not resolve the misbehavior, please collect the log files generated during the test run attempt after restarting the setup and send these over this thread for further investigation. 

    Thank you in advance for your cooperation. I am looking forward to hearing back from you what the outcome is. 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top