This is a migrated thread and some comments may be shown as answers.

Test execution working fine but not working with TFS build

5 Answers 35 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Atul
Top achievements
Rank 1
Atul asked on 12 Nov 2013, 10:13 AM
Hello Team,
i am trying to run my run my test case , and when run test case from telerik test explorer it works fine.
but when bind it to TFS its not working. and shows such errors:

Overall Result: Fail------------------------'12-11-2013 14:01:42' - Using .Net Runtime version: '4.0.30319.18052' for test execution. 

'12-11-2013 14:01:42' - Starting execution....
 - Detected a Silverlight Test. Setting EnableSilverlight=True'12-11-2013 14:01:48' 

- Detected custom code in test. Locating test assembly: Test Project.dll.

'12-11-2013 14:01:48' - Assembly Found: C:\Builds\15\AutomatedTesting

Thanks in advance

5 Answers, 1 is accepted

Sort by
0
Ivaylo
Telerik team
answered on 15 Nov 2013, 08:52 AM
Hello Atul,

I am sorry you are experiencing this issue. 
Could you please provide us with more information on this, the one you provided is not an actual error, this is the start of the execution of the test which is not helpful at this point. Please provide the exception and elaborate on the issue. Are you trying to use the scheduling functionality and using get latest from TFS option?

Looking forward to hear from you with more details.

Regards,
Ivaylo
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Atul
Top achievements
Rank 1
answered on 18 Nov 2013, 05:05 AM
Hi lvaylo,
             Thanks for your help,but sir we don't have any more details,it showing up-to this only.

Thanks in advance
0
Ivaylo
Telerik team
answered on 20 Nov 2013, 02:16 PM
Hello Atul,

You can provide me with the application log so I can examine it for any errors thrown. Here is an article on how to proceed. Please make sure you clear the log first and then reproduce the issue. Any screenshots of errors or short videos that can provide more information are also welcome.

Looking forward to hear from you.

Regards,
Ivaylo
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Atul
Top achievements
Rank 1
answered on 21 Nov 2013, 05:50 AM
 Hello lvaylo,
                   Thanks for your help.
I am sending you error message , Please give solution ,how to handle this error.
and also i had done some setting from my side to remove this error
please refer screenshot.

thanks in advance

------------------------------------------------------------
'20-11-2013 12:51:48' - Using .Net Runtime version: '4.0.30319.18052' for test execution. Build version is '2013.1.911.0'.
'20-11-2013 12:51:48' - Starting execution....
'20-11-2013 12:51:48' - Detected a Silverlight Test. Setting EnableSilverlight=True
'20-11-2013 12:51:50' - Detected custom code in test. Locating test assembly: TestStudioProject1.dll.
'20-11-2013 12:51:50' - Failure detected during execution. Details:
------------------------------------------------------------
'20-11-2013 12:51:50' - System.IO.FileNotFoundException: Unable to find the code behind assembly. Please make sure you have compiled your code behind without errors before attempting to execute the test. Looking for: D:\Demo\New Folder\BuildServerPOC\TestStudioProject1\TestResults\atul.vishwakarma_ATUL-VISHWAKARM 2013-11-20 12_51_47\Out\TestStudioProject1.dll
If you are running VS 2010, make sure Deployment is checked in your .settings file (in the solution items)
   at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.EnsureAssemblyExists(String assembly, String folder)
   at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.CreateCodedTestInstance(Test test, TestResult result, String binariesFolder)
   at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.InternalExecuteTest(Test test, TestResult initializationResult)
   at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(ExecuteTestCommand command)
------------------------------------------------------------
'20-11-2013 12:51:50' - Test completed!
0
Ivaylo
Telerik team
answered on 25 Nov 2013, 03:59 PM
Hello Atul,

Could you please also provide me with a screenshot of with the content of this folder:

D:\Demo\New Folder\BuildServerPOC\TestStudioProject1\TestResults\atul.vishwakarma_ATUL-VISHWAKARM 2013-11-20 12_51_47\Out\

Please also attach the settings file in this thread.

Looking forward to hearing from you.

Regards,
Ivaylo
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Atul
Top achievements
Rank 1
Answers by
Ivaylo
Telerik team
Atul
Top achievements
Rank 1
Share this question
or