Silverlight Test Fails in Firefox

4 posts, 0 answers
  1. Aaron
    Aaron avatar
    28 posts
    Member since:
    May 2012

    Posted 16 Nov 2012 Link to this post

    We got some problems running Silverlight tests on Firefox (16.0.2). The test stops as soon as the first element in the Silverlight app is accessed. This is the log message:

    Outer Exception Type: System.TimeoutException
    Message: Timeout trying to connect to Silverlight App.

    A complete log is attached.
    The tests run successfully on IE and Chrome. Firefox is configured manually according to the documentation and the Telerik Extension is installed. We are using Test Studio Vesion 2012.2.920.0.
  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 16 Nov 2012 Link to this post

    Hello Aaron,

    Thank you for providing the log file. I wasn't able to reproduce the problem you are experiencing as you can see in this video. However judging from the error you are getting, you probably need to enable the Silverlight automation from the Test Properties. If you are running your test as a part of a Test List, there is an equivalent property EnableSilverlight. You'll find it in the Test List Settings under the Web tab. 
     
    Also, try to increase the Silverlight Connect Timeout in Project Settings > Recording Options.

    Regards,
    Plamen
    the Telerik team
    Are you enjoying Test Studio? We’d appreciate your vote in the ATI automation awards.
    Vote now
  3. Aaron
    Aaron avatar
    28 posts
    Member since:
    May 2012

    Posted 23 Nov 2012 Link to this post

    Unfortunately your tips didn't help. I attached a project with 2 tests. Both "tests" are working fine in IE and Chrome and fail in FF. Additionaly I tried to disable all addons in Firefox (except for the Telerik) but same error as before.
  4. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 23 Nov 2012 Link to this post

    Hi Aaron,

    As you can see in this video, I just increased the "Silverlight Connect Timeout" and I was able to execute both tests in Firefox successfully. I also noticed that you are using an older version of Test Studio. Please upgrade to our latest internal build(2012.2.1022) and try to execute these tests again. You can download it from your Telerik account here: Public URL.

    Kind regards,
    Plamen
    the Telerik team
    Are you enjoying Test Studio? We’d appreciate your vote in the ATI automation awards.
    Vote now
Back to Top