Scheduling Service Failing to Start

6 posts, 0 answers
  1. Zachary
    Zachary avatar
    21 posts
    Member since:
    Dec 2010

    Posted 18 Feb 2011 Link to this post

    Hi,

    I am currently evaluating WebUI QA edition. As of yesterday, I had the scheduling and executing servers set up. After a reboot today, I am unable to schedule tests. My execution server is no longer registered. And when I try to make a test connection to the scheduling server inside of WebUI QA (Project tab), it says that the Scheduling service is not running. When I try to click on "Configure as a Scheduling Server" the window pops up with everything greyed out. I go into Windows services to try and start the WebUI Secheduling service manually, but it says something to the effect of: "the service started and then stopped" and "Some services stop automatically if they have no work to do..."

    I am running a VM with Windows Server 2003 SP2.

    I would appreciate any help you can offer. Thanks.
  2. Stoich
    Admin
    Stoich avatar
    1 posts

    Posted 19 Feb 2011 Link to this post

    Hello Zachary,

        the Scheduling service has stopped running and you need to manually start it. Check this out:
    http://www.telerik.com/automated-testing-tools/support/kb/scheduling/resolving-some-common-scheduling-issues.aspx#C3

    Make sure the service stays "running" - sometimes when there's a problem it will immediately switch back to stopped after you manually start it. We want to make sure this is not the case.

    Let me know if the problem persists!

    Kind regards,
    Stoich
    the Telerik team
  3. Deepak
    Deepak avatar
    17 posts
    Member since:
    Jun 2012

    Posted 21 Jun 2012 Link to this post

    Hi Stoich,

    I am getting the error "Scheduling Service is not running" and when i tried to start manually from services.msc it starts and it will immediately switch back to stopped with an windows error message "The Telerik Test Studio Scheduling service service on local computer started and then stopped. Some services stop automatically if they have no work to do for example performance logs and alert services"

    Kindly Suggest.

    Thanks in Advance..
  4. Stoich
    Admin
    Stoich avatar
    1 posts

    Posted 26 Jun 2012 Link to this post

    Hello Zachary,
    I apologize for the late response.

    This is probably related to permissions that your user account is missing. Try with a different user account if possible (one with more permissions/admin rights). Go ahead and send us the Scheduling Log. It is located in Test Studio's installation folder. By default its location is:
      • C:\Program Files (x86)\Telerik\Test Studio\Bin\Telerik.TestStudio.Scheduling.Log.exe

    You can export it and send it to us.

    Regards,
    Stoich
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  5. Deepak
    Deepak avatar
    17 posts
    Member since:
    Jun 2012

    Posted 26 Jun 2012 Link to this post

    Hi Stoich,

    Please find attached Scheduling Service log.

    Thanks,
    Deepak
  6. Stoich
    Admin
    Stoich avatar
    1 posts

    Posted 02 Jul 2012 Link to this post

    Hi Zachary,
    the first thing you should try is to recreate your database as seen in this video:
    http://screencast.com/t/TdNFX3P3Zh7
    Make sure you've configured the SMTP settings correctly (discuss with your Sys admins if necessary). Let me know if this doesn't help.

    Regards,
    Stoich
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top