This is a migrated thread and some comments may be shown as answers.

Saving a file results in a Storage service unavailable error

18 Answers 26 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Efficio
Top achievements
Rank 1
Efficio asked on 29 Jan 2020, 03:05 PM
I am getting the "storage service unavailable" error dialog quite often.  As I recall I used to get this intermittently when I had the application installed locally, and it also happens with the installation we have on our server.  Both the application and the execution server are installed on the same machine.  I initially ignored it since it didn't seem to affect anything (aside from being really annoying) and was intermittent, but from what I can tell it is causing the execution server to run outdated versions of our tests.

It is really happening a lot now, and I don't know what is causing it.  Based on a few tests I noticed that I was able to get it to go away by running a test list remotely.  I saw some references to this online, and I tried the steps of "reapplying" everything which seems to reconfigure/reinstall MongoDB, the Storage Server, and the Scheduling Server.  I did notice that the one scheduled tests list I have seems to have stopped running possibly as a result of these actions so I need to look into that as well.

This seems to be the relevant error in the log file.  I assume UploadToCloudAsync is correct even though the service is installed locally in our case.

[01/29 09:37:41,Telerik.TestStudio.Desktop.exe(21088:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function Start -------
[01/29 09:37:42,Telerik.TestStudio.Desktop.exe(21088:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function End -------
[01/29 09:37:43,Telerik.TestStudio.Desktop.exe(21088:1),TestStudio] StandaloneHost.UpdateScheduledJobsToStorage() : EXCEPTION! (see below)
     Outer Exception Type: System.NullReferenceException
     Message: Object reference not set to an instance of an object.
     HRESULT: 0x80004003 (Official ID (if app.) = E_POINTER, Error Bit = FAILED, Facility = FACILITY_NULL, Code = 16387)
     Call Stack:
          at ArtOfTest.WebAii.Design.Repository.StorageUploader.<UploadToCloudAsync>d__3.MoveNext()
          --- End of stack trace from previous location where exception was thrown ---
          at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
          at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
          at ArtOfTest.WebAii.Design.Repository.Commands.UploadToCloudCommand.<ExecuteAsync>d__11.MoveNext()
          --- End of stack trace from previous location where exception was thrown ---
          at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
          at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
          at ArtOfTest.WebAii.Design.ProjectModel.StandaloneHost.<UpdateScheduledJobsToStorage>d__243.MoveNext()

18 Answers, 1 is accepted

Sort by
0
Elena
Telerik team
answered on 03 Feb 2020, 11:45 AM

Hi,

I am sorry to know you are having troubles with the Test Studio Scheduling setup and will be happy to assist you with sorting these out. 

It seems you have performed the initial troubleshooting steps to reconfigure the Test Studio services. Though, you still get the mentioned error and probably there is something beyond this, which we need to find out. 

Here are few steps you can follow and collect some further details for me:

  1. When you open the 'Configure Scheduling wizard' and click on the 'Apply' button for each tab, does the informational message in the lower left bottom reports the service (or MongoDB for the respective tab) is running? 
  2. If you open the Execution Status view, what is the state of services reported? Can you share a screenshot of this? 
  3. Basically, I suspect that the MongoDB database got corrupted at some point and ever since cannot be fully utilized. To fix this, you can drop the whole database or single collections, if you need the results generated so far. Dropping these, will force MongoDB to recreate the missing pieces in the database and there will be no corrupted data. Here you can read further how to drop the whole database or single collections. 
  4. If you drop the database, then perform step 1. from the listed here, and reschedule the existing jobs. 

In case these suggested steps do not change anything in the behavior of remote test list execution, please take the time to elaborate on the particular setup you have and to collect the mentioned screenshots

  • how many machines there are in your Scheduling setup and which is the one hosting the Test Studio Services? 
  • can you send me a screenshot of the Execution status view?
  • can you send me a screenshot of each tab in the Scheduling config wizard?
  • can you clear the logs on both the execution and Services machines, then trigger a remote/scheduled job and collect the generated log files - please, send these zipped for further investigation.

Please, do not hesitate to share any other details, you might find relevant to the current discussion. I will be looking forward to hearing back from you. Thank you in advance for your cooperation. 

P.S. A side note in this discussion is I noticed the account, you have submitted your query from, does not have a Test Studio license assigned. Thus, you can only submit forum threads, which due time is longer than a support ticket. So, if you use the account with email address rnoecker@efficiosolutions.com, you will get support responses in shorter terms. 

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 03 Feb 2020, 02:54 PM
1) When I initially open the wizard all the tabs except for MongoDB have a message at the bottom (ex. "...is running").  If I apply on the MongoDB tab it shows the "MongoDB is started" message.  For the other tabs, they all say the service is started after I click apply.

2) Everything shows as being alive/online in the execution status view.

3) I have suspected the MongoDB database if that is what is being used by to in remote test execution to get the tests.  Even when the error isn't happen I'm not convinced that the test are always being updated properly, however, it is definitely updating in some ways since newly created tests have been showing up.  I'm not even sure this would be an issue if I went with "get latest from source control", but that feature didn't work for me the last time I tried it so I'll probably be creating an issue for that next.

4) I dropped the TSStorageData database in MongoDB.  I then went through the Configure Scheduling tabs and applied again.  I edited the scheduled task that I had, but that didn't appear to recreate the database so I executed a test list remotely, and that caused it to be recreated.  At this point I can save files without the error, but as I mentioned I was already able to use running a test list remote to make the error go away, but it would come back.  Also I'm not positive that the tests are always being updated correctly even when I don't get the error.  I'll have to keep using it and wait to see if the error comes back or if I see a test that is out of date during the scheduled run.

If the error happens again I will collect the additional information as requested and post it here.
0
Efficio
Top achievements
Rank 1
answered on 03 Feb 2020, 03:06 PM
The license is under Justin.locke@share-builders.com since it was incorrectly purchased under a different account. I don't want to post under that since I won't get the emails.  I may need to look into transferring the license if possible.
0
Efficio
Top achievements
Rank 1
answered on 03 Feb 2020, 03:22 PM
I changed the licensed developer under the account that owns the license to this account.  Hopefully that helps.
0
Elena
Telerik team
answered on 06 Feb 2020, 09:49 AM

Hello,

I am pleased to know that deleting the Mongo database did help with restoring back the remote runs. With the details we managed to gather before that, I am not able to determine what might have caused this. I hope you will not face the same issues again, however, do not hesitate to contact me back in the case of need. 

In regards the upload of the test files to the storage database - by default this will be triggered when the scheduled job is set to start. If you need to upload the project files before that, you can click with the right mouse button on the upcoming scheduled job in the Calendar view in Test Studio, to choose the option to upload the necessary files to storage - please, see the Manual upload section in this article

This upload can be also done automatically on each Save all action (Ctrl + Shift + S or the Save button on the upper left corner of the Test Studio window). Possibly you might have clicked away that message and following the steps listed in the second section of this article, you can find how to bring this back and set the desired option. Let me know if you have any troubles with that. 

Apart from the actual topic in this thread, I checked your account and it seems that the license is not assigned to it. So, by submitting your next query, you should benefit from the support service in shorter terms. And in regards getting email notifications from a thread, you can add any recipients in the CC field and they will get an email notification by each reply in the ticket. 

Thank you for your cooperation in our conversation. I will proceed closing the current thread and please, do not hesitate to reopen it in case of need or reach out to us by submitting another.

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 06 Feb 2020, 03:40 PM

I haven't been getting "storage unavailable error" for the last few days, however, I followed the steps in the article posted about resetting the save option and now it is back.

I checked the PerUserSettings.json file, and the setting was already true, but I went ahead and deleted it.  I then reloaded the project, made a change to a step, and saved (Ctrl+S) and got the dialog.

By the way, this auto upload behavior seems to be triggered by a regular save and just save all. I don't even see a way to save a single file or know what Ctrl+S is mapped to.  I assume the individual save (which according the settings file I have the prompt disabled for) is triggered by things like running an unsaved test (closing an unsaved file strangely enough doesn't trigger a save).  Regardless, Ctrl+S triggers this dialog.

In the dialog I selected the "do not prompt" option and clicked cancel.  This added the entry in the settings file with a value of true.  The problem is that immediately after doing that the next save resulted in the "storage service unreachable" and it happens on every save.  Based on my testing, it seems like the upload to the storage server happens every time and the only way to cancel it is through the dialog.  Selecting the "do not prompt" and clicking cancel only avoids the upload for that time and after that it will just upload every time (i.e. that part isn't configurable).  Based on further testing, the error coming back seems due to the fact that I had to close and reload the project in order for the setting change I made in PerUserSettings.json to take effect.

Of course this all brings me back to the one workaround I stumbled on which is to pick a random test list and run it remotely.  After that saving a test works.  Here is the log from changing a step and then saving.

[02/06 10:35:03,Telerik.TestStudio.Desktop.exe(17804:1),TeamFoundationServer] TFSServer.QueryStatus() : ------- Function Start --
[02/06 10:35:03,Telerik.TestStudio.Desktop.exe(17804:1),TeamFoundationServer] TFSServer.QueryStatus() : ------- Function End ---
[02/06 10:35:03,Telerik.TestStudio.Desktop.exe(17804:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function Start
[02/06 10:35:04,Telerik.TestStudio.Desktop.exe(17804:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function End

 

If I close the project and reopen it I get the "storage service unreachable" error on my first attempt to save.

[02/06 10:37:46,Telerik.TestStudio.Desktop.exe(832:1),TeamFoundationServer] TFSServer.QueryStatus() : ------- Function Start ------
[02/06 10:37:46,Telerik.TestStudio.Desktop.exe(832:1),TeamFoundationServer] TFSServer.QueryStatus() : ------- Function End -------
[02/06 10:37:46,Telerik.TestStudio.Desktop.exe(832:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function Start ---
[02/06 10:37:46,Telerik.TestStudio.Desktop.exe(832:1),TestStudio] StorageUploader.UploadToCloudAsync() : ------- Function End ----
[02/06 10:37:48,Telerik.TestStudio.Desktop.exe(832:1),TestStudio] StandaloneHost.UpdateScheduledJobsToStorage() : EXCEPTION! (see below)
     Outer Exception Type: System.NullReferenceException
     Message: Object reference not set to an instance of an object.
     HRESULT: 0x80004003 (Official ID (if app.) = E_POINTER, Error Bit = FAILED, Facility = FACILITY_NULL, Code = 16387)
     Call Stack:
          at ArtOfTest.WebAii.Design.Repository.StorageUploader.<UploadToCloudAsync>d__3.MoveNext()
          --- End of stack trace from previous location where exception was thrown ---
          at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
          at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
          at ArtOfTest.WebAii.Design.Repository.Commands.UploadToCloudCommand.<ExecuteAsync>d__11.MoveNext()
          --- End of stack trace from previous location where exception was thrown ---
          at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
          at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
          at ArtOfTest.WebAii.Design.ProjectModel.StandaloneHost.<UpdateScheduledJobsToStorage>d__243.MoveNext()

0
Elena
Telerik team
answered on 11 Feb 2020, 11:37 AM

Hello,

I am sorry to know that you get the error consistently again.

The described behavior is quite inconsistent and not expected - the scheduled tests are being executed successfully, but still the "Storage unreachable" message is there. To sort out what we might have missed so far, I went through all details shared so far and analyzed these once again. 

Hopefully, I may have found what is causing this warning message and here are the next steps I can suggest: 

  1. Exit all Test Studio processes and stop the services - open Windows Services and manually stop these.
  2. Delete any leftover scheduled jobs - each upcoming scheduled job (recurring or not) is a file physically stored on the disk. Depending on the Scheduling setup you have configured, these files can be stored in few different locations listed in point 2. in this article. I guess the location you need to look for is the one for 64-bit machine - C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Telerik\TestStudio\Scheduler\ScheduleStorage. 
  3. Once you open the correct location, there will be listed all current scheduled jobs and possibly any leftover. Basically, you can delete all these and then newly schedule the desired test lists from Test Studio afterwards. Or, you can try finding the old jobs using the last modified date as a hint. 
  4. Once you have removed any jobs, which are not relevant anymore, you can start the Scheduling Config wizard and start the services from there.
  5. Then start Test Studio and try to reproduce the warning message appearance.

Please, let me know if that changes the misbehavior, or if not, what the outcome of this was.

Thanks once again for your continuous cooperation.

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 11 Feb 2020, 04:20 PM

I only had a single job file.  I deleted it, opened Test Studio, went through the wizard and click the apply button for each to install/restart the services.

I modified a file and saved and did not get an error.  I assumed this was because there wasn't a scheduled job so it wouldn't try to contact the storage server, and I verified this in the log file which only shows a call to the TFSServer.QueryStatus() function.

I scheduled the job that includes all tests in a dynamic test list.  I modified a file and saved.  I did not get an error.  I verified in the log file that the StorageUploader.UploadToCloudAsync() function is being called.

I closed the reopened Test Studio.  I modified a file and saved, and the "storage service unavailable" error is back.  I should add that this error dialog pops up immediately on saving, and it doesn't seem to be the result of a timeout or connection error.

My workaround at this point has been to remotely run a job (any job it seems) and then the error goes away until I restart Test Studio.  I found a new workaround in that just clicking on the Test Lists or Results tab and then back to the Project tab makes the error go away.  Whatever is happening (on these tabs or maybe just because the project tab was left) resolves the issue.  After I do this and save the first save takes a few seconds so it is actually doing something and subsequent saves are quicker.  I've included the log of what happens when I go to the Test Lists tab after loading a project.

Something is definitely off and this is 100% reproducible, but we at least have a workaround at this point so we aren't losing a ton of time dealing with the error dialog on every save.

[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:46)] First trace message from pool unnamed thread (managed ID = 46, native ID = 3284).
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:46),Uncategorized] <>c__DisplayClass8_1.<Refresh>b__0() : Enumerating test list files in "C:\Efficio\TelerikTestStudio\Efficio Main Application\TestLists"...
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:46),Uncategorized] <>c__DisplayClass8_1.<Refresh>b__0() : 8 test lists found.
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:21)] First trace message from pool unnamed thread (managed ID = 21, native ID = 14064).
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:21),Uncategorized] <>c__DisplayClass8_1.<Refresh>b__1() : All files parsed and 8 viewmodels added.
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:20,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.ConnectToServer() : ------- Function End -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function Start -------
[02/11 11:15:21,Telerik.TestStudio.Desktop.exe(2632:1),TeamFoundationServer] TFSServer.AttachToRepository() : ------- Function End -------


0
Elena
Telerik team
answered on 14 Feb 2020, 09:24 AM

Hi,

Thank you for the thorough description of your actions - this is always helpful for us to understand the current situation.

The occurrence on your end is, though, really odd and not expected. I just want to mention few things, which will address your doubts based on the shared details in your last response. As you suggested, Save action in Test Studio will contact the Storage Service only if there are upcoming scheduled jobs. However, the only tab in Test Studio, which triggers communication to the Storage, is the Results tab and this communication is in the direction Storage -> Test Studio. Having that in mind, the appearance of the error becomes more and more strange. 

There are few more things you can verify, though. 

Reconfigure the services to use IP address

Although this is a single machine setup, I would like to check the behavior if the Test Studio services are configured with IP address. So, can you, please, open the Scheduling setup wizard and replace the machine name (or localhost) in the Scheduling and Storage tabs with the IP address of the machine. Hitting the Apply button will update the modified info. 

Then, open the Test Studio project and connect it also using the IP address. Is there any difference in the behavior on the Save action?

Review the files in the project root folder

Please, take the time to review what files you have in the project's root folder apart from the test files and the related to them files. What might be causing some troubles with the storage are any files or folders, which are not directly related to the project and are not controlled from Test Studio, but are stored in the project folder. These can be any kind of files you are using somehow along with the project, but since Test Studio does not recognize these, it simply sends these to the Storage database in the case of scheduled jobs. If there are such files and these are quite large, this could be affecting somehow the communication between the project and storage. 

Check the other folders, where a scheduled job could be stored

Please, check the folder for local scheduled jobs as well and delete any leftover files in it - C:\Users<yourUserName>\AppData\Roaming\Telerik\TestStudio\Scheduler\ScheduleStorage. Possibly, this could be something you have configured before you added the Test Studio services and it now could be triggering the message.

I hope that we will manage to drill down the root cause of this message. If none of these suggestion helps, my next idea is to conduct a live online troubleshooting session - possibly there is something we are missing in between the rest of the details and a live screen share session will help us identify what it is. So, please, let me know which is the time zone you are in and what your availability for next week is - this will help me find the most suitable time frame for both side, if a meeting is required. 

Thank you once again for all your efforts in this case.

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 14 Feb 2020, 04:52 PM
I changed the IP for the scheduling server.  I tried for the storage server but the textbox just shows a red border which appears to be a validation error, but it doesn't actually give a message, and the only way to enable the apply button again is to click the "reset to default" button.  I still get the error after restarting Test Studio.  Given that the error happens immediately I wouldn't think there is a connection timeout or anything, also the log shows a null reference error in the upload method not anything clearly networking related.  Also, if I just change to the Test Lists tab and back it starts to work.

I don't see any files in the folder that aren't Test Studio related.  We have some CSV files for data binding in a Data folder.  Again, considering that this works once I get past the error and the error happens immediately, I wouldn't think it is a networking issue.

I have a file in my local ScheduleStorage folder from 10/10/2019.  I deleted it.  I still get the error after restarting Test Studio.

I also took one more step as I noticed that the scheduler file in C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Telerik\TestStudio\Scheduler\ScheduleStorage has a NETBIOS name it.  I changed it to localhost and an IP address and still got the error after restarting Test Studio.
      "Credentials": {
        "StorageUri": "http://STAGING:8492/v1/"
      },

We are US EST (-5 GMT).  We should be relatively flexible next week on time and day.
0
Elena
Telerik team
answered on 18 Feb 2020, 08:45 AM

Hello,

I will block the time frame on Thursday 2/20/2019, 9:00 - 10:00 AM EST and will also list the meeting details below. However, if this is not a suitable frame for a meeting as of your perspective, please, do not hesitate to get back to me with a reschedule suggestion. 

Thanks once again for all your cooperation in our discussion.

1451363 - Saving a file results in a Storage service unavailable error 
Thu, Feb 20, 2020 9:00 AM - 10:00 AM EST (4:00 PM - 5:00 PM EET)

Please join my meeting from your computer, tablet or smartphone. 
https://global.gotomeeting.com/join/676022485  

You can also dial in using your phone. 
(For supported devices, tap a one-touch number below to join instantly.) 
United States (Toll Free): 1 877 309 2073 
- One-touch: tel:+18773092073,,676022485# 
United States: +1 (571) 317-3129 
- One-touch: tel:+15713173129,,676022485# 

Access Code: 676-022-485 

More phone numbers: 
(For supported devices, tap a one-touch number below to join instantly.) 
Canada (Toll Free): 1 888 455 1389 
- One-touch: tel:+18884551389,,676022485# 
Canada: +1 (647) 497-9391 
- One-touch: tel:+16474979391,,676022485# 

Join from a video-conferencing room or system. 
Dial in or type: 67.217.95.2 or inroomlink.goto.com 
Meeting ID: 676 022 485 
Or dial directly: 676022485@67.217.95.2 or 67.217.95.2##676022485 

New to GoToMeeting? Get the app now and be ready when your first meeting starts: https://global.gotomeeting.com/install/676022485

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Elena
Telerik team
answered on 20 Feb 2020, 04:13 PM

Hi Richard, David,

Thank you for your cooperation today during our meeting. 

I will summarize below what we managed to explore in our conversation. Basically, we started with all suggested troubleshooting steps so far

- re-apply the Test Studio services settings, reconnect the project and the Test Runner. 
- check for and delete any leftover scheduled jobs under all users, that may have created such. 
- create a new project to check if the issue is project specific. 
- recreate the Test Studio services config files.

Since none of these brought any change in the misbehavior, we suspect that the issue is related to anything else in the so far applied configurations. Having this in mind, the next suggestion we have is to perform a new clean installation of Test Studio and I will list below the steps you need to follow for this: 

  1. Login to the machine with the Tester user - the one you are using for the automation.
  2. Deactivate the license of Test Studio as described here
  3. Open the Windows Control panel and uninstall Test Studio.
  4. Check if there are any leftover files in the installation folder C:\Program Files (x86)\Progress\Test Studio and delete these, if applicable. 
  5. Check the Program Data folder C:\ProgramData\Telerik and delete any leftover files, if applicable. 
  6. Check the user's folder C:\Users\<userName>\AppData\Roaming\Telerik\TestStudio for any users, that may have started Test Studio, and delete any leftover files. 
  7. Check the user's folder C:\Users\etsvetko\AppData\Roaming\ArtOfTest and delete any leftover files.
  8. Check the system profile folder C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Telerik and again delete the content if there are any leftover files.
  9. There shouldn't be no files in the system profile folder C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\ArtOfTest but still you can check this as well.
  10. Download the latest version of Test Studio available in your Telerik account here and install it on the machine.
  11. Be sure to enable the Test Studio services in the installation wizard
  12. Once finished, open the sample project we created during the meeting and apply the Services configuration using the default localhost values.
  13. Open the Test Runner and check if this is connected to the Scheduling service. 
  14. Connect the project to service on localhost as well.
  15. Schedule the sample test list for any time in the future - allow yourself some time to test the behavior.
  16. Now reopen Test Studio in order to have the setup when you reproduced the error message before.
  17. Make any change in the test and hit Ctrl+S. What the outcome of this will be? 
  18. If that works, test it with the actual project you have built.

I am looking forward to hearing back from you once you have the time to perform these recommended steps. Please, note that we will continue working on the case if you still face any troubles, so, please do not hesitate to share any questions or concerns you may have.

Thank you once again for your time spent on this investigation. 

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Elena
Telerik team
answered on 26 Feb 2020, 04:36 PM

Hi Richard, David,

Let me step back in this discussion. I wanted to check if you had the time for the follow up steps we agreed upon during the meeting. 

In addition to that, there is a much easier suggestion I have come up with - if you hadn't proceeded with reinstalling Test Studio so far, you can try restarting the Test Studio services. You can do this either through the Windows Services, or the Test Studio Scheduling config wizard - reapplying the settings will restart the services. 

I remember that it wasn't an option to restart the server machine on which is also hosted Test Studio, so possibly you do not reboot this machine on a regular basis. Thus, the stuck scheduled job, which probably causes the 'Storage Unreachable' error, may not exist as an actual file anymore, but in some broken state in the cache of the Scheduling service. A restart of the service should clear this. 

Please, get back to me once you have the chance to test this, if the suggestion is still applicable. Thank you once again for your cooperation. 

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 02 Mar 2020, 02:26 AM

I did the the steps to restart the services and still got the error.

I then did the steps to completely uninstall Test Studio then reinstall it, and I still get the error in the test project.  I'm pretty sure I did, but I can double check tomorrow that I followed them exactly.

There is obviously something wrong, but I don't really think it would be a configuration error as my configuration should be the default at this point.  I also don't think that any configuration error should cause this error given that just changing the active tab to the results tab (which I believe you said doesn't do anything with the scheduling server) resolves the issue.  There seems to be something that is initialized just by changing the tab.

You may need to work with your development team to see what code could be causing a null reference exception in this scenario.  At this point we will just have to work around this problem.  It isn't a real burden to do so now that we have a workaround, but I wonder if it could cause any other issues we aren't aware of at this time.

0
Elena
Telerik team
answered on 02 Mar 2020, 11:54 AM

Hello,

Thank you once again for your cooperation in this investigation. 

Certainly I will proceed the discussion on my end with the development team - we performed all possible troubleshooting steps, ensured a clear installation without any leftover config data, etc. and still the message appears on project start. So, I will share all details collected so far with my dev team and will continue the research in further depth. 

I am pleased to know that the workaround you have is satisfying for now and highly appreciate your understanding and efforts spent on the case. If we need your further assistance, I will contact you back in this thread. 

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Elena
Telerik team
answered on 05 Mar 2020, 08:29 AM

Hi Lucas,

I just want to share some good news with you - the development team had the chance to dig into the issue and it turned out the issue was within the product. When initially starting the project, the test lists were not loaded and initialized and thus the upload action fails because of the missing parameters. Then, once you switch the tabs, the test lists gets loaded and the error does not appear anymore. 

Anyways, there is a fix implemented already and will be available with our next official release expected until the end of the month.

Thank you for all your cooperation throughout this investigation.

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Efficio
Top achievements
Rank 1
answered on 05 Mar 2020, 02:50 PM
Great.  We will await the next release and test again then.
0
Elena
Telerik team
answered on 05 Mar 2020, 03:46 PM

Hi Lucas,

Thank you for your patience on the case. Once you get the update notification, please, take the time to test this and do not hesitate to get back to us in case you experience the same again. 

In the meantime, I will close the current thread, but you can reopen it at any time by posting a new message in it.

Regards,
Elena
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Efficio
Top achievements
Rank 1
Answers by
Elena
Telerik team
Efficio
Top achievements
Rank 1
Share this question
or