Running tests with WebAii free version after Test Studio install

4 posts, 0 answers
  1. Sandy
    Sandy avatar
    8 posts
    Member since:
    Jun 2011

    Posted 20 Jul 2011 Link to this post

    After installing the Test Studio trial edition, tests created using the WebAii framework (free version) no longer run on the same box that Test Studio is installed. Our trial ended with a purchase of the commercial license, but we'll need to continue running tests on the existing framework until we can migrate completely.

    The error I'm getting is:

    Unit Test Adapter threw exception:
    Could not load file or assembly 'ArtOfTest.Common, Version=2010.3.1307.0, Culture=neutral, PublicKeyToken=14a0200bfcbb7b62' or one of its dependencies. The system cannot find the file specified..

    I don't quite understand what could be the problem. The file in error is still in the same place as it was before the trial install. 

    I'm using
    Visual Studio 2010
    ArtofTest WebAii
    Microsoft Test Tools
    Silverlight UI testing

  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 21 Jul 2011 Link to this post

    Hi Sandy,

    WebAii framework is part of Test Studio, so you can continue executing your test on the framework. You can resolve your problem easily by removing the "ArtOfTest.Common.dll" assembly reference and rebuild your projects, This is needed because the assembly is no longer included in Test Studio and its functionality is transferred to "ArtOfTest.WebAii.dll".

    Greetings,
    Plamen
    the Telerik team
    Register today for a live 'What's New in Test Studio R1 2011 SP2' event on Tuesday, July 19 at 2pm EST!

    Have you looked at the new Online User Guide for Telerik Test Studio?
  3. Sandy
    Sandy avatar
    8 posts
    Member since:
    Jun 2011

    Posted 21 Jul 2011 Link to this post

    Ok, so I could have my older tests referencing the same up to date framework that Test Studio installed. That would require a little code cleanup since some initialization settings referenced using the old framework are obsolete in the new framework.

    I was thinking I could simply launch the older tests "as is" since that framework is installed in a completely different folder and the project references the files in that location.



  4. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 22 Jul 2011 Link to this post

    Hi Sandy,

    That is correct. There is no way to use the old  framework and the new framework on the same machine. While installing Test Studio is deleting all old references from the Global Assembly Cache(GAC), no matter the two frameworks are in different folders. 
     
    I am sorry for the inconvenience.

    Greetings,
    Plamen
    the Telerik team
    Register today for a live 'What's New in Test Studio R1 2011 SP2' event on Tuesday, July 19 at 2pm EST!

    Have you looked at the new Online User Guide for Telerik Test Studio?
Back to Top