Run test case

4 posts, 0 answers
  1. Talal
    Talal avatar
    19 posts
    Member since:
    Jan 2012

    Posted 20 Feb 2012 Link to this post

    1. When I run the test case by it self not errored while when I run same test case within a list of test cases it's fail, while it should pass any clue?
    2. The result of some test cases not consistent some time it's fail and other time it's pass, for example in the the execution of the Login, test "pass" because it's enter the UserId in full as recorded and other time "fail" because it doesn't enter the UserId in full as recorded, any idea way it does that? 

    When I record the test case and play it again and it pass, it should always pass unless some thing get change. But that is not the case, any idea? how I improve the recording of the test cases to make it consistant
  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 23 Feb 2012 Link to this post

    Hi Talal,

    I'm sorry you are experiencing this problem. Is this an HTML or a Silverlight app that you are testing? I will need some additional details about the failure in order to troubleshoot any problems you might be experiencing. See here for what information to provide. If you feel that information is sensitive, you can submit a support ticket which is confidential, unlike this forum.

    In the meantime, here are some things to try: 
    1. Usually when you're experiencing inconsistencies in test runs, the problem is related to timing issues. Please check this article and see if this will help you resolve the first problem.

    2. For the second problem you can try to set the SimulateRealTyping or SimulateRealUser properties to true in the Test Step Properties

    All the best,
    Plamen
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  3. Talal
    Talal avatar
    19 posts
    Member since:
    Jan 2012

    Posted 23 Feb 2012 Link to this post

    Hi Plamen,

    The application is Silverlight application, if it's happen again I will send you all the information you want, but in general if you have some advices to avoide this problems please let me know, thanks

    Talal
  4. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 28 Feb 2012 Link to this post

    Hello Talal,

    For Silverlight applications you can also try to increase the Silverlight Connect Timeout in Project Settings > Recording Options if your app requires a longer load time. There is also a corresponding setting on the Web tab of Test List Settings (see screenshot).

    If you hit this problem again, please let us know.

    Regards,
    Plamen
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top