This is a migrated thread and some comments may be shown as answers.

Refreshing on no page load

5 Answers 14 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Tim
Top achievements
Rank 1
Tim asked on 21 Nov 2019, 08:41 AM
I have an issue where my initial URL is not loading at all but cannot handle it as the next steps are not being triggered until the page loads.  I have tried to add a While loop which delays for 5 seconds and then tries a Browser Refresh, but as I TS can't even get to the while step the page cannot be refreshed.  Is there a code snippet which can identify when the page does not even start to load?

5 Answers, 1 is accepted

Sort by
0
Plamen Mitrev
Telerik team
answered on 22 Nov 2019, 12:12 PM

Hi Tim,

I am interested to analyze the test that you have and gather more details about the misbehavior. Please share more details on the topics below.

  • When the test execution starts, the browsers and the Test Studio extensions are loaded and it initially opens localhost. Then the first steps is executed and it is usually a "Navigate to" step. You should see the URL change and the page starting to load. Please let me know if that is not the case and share more details on the behavior.
  • Please zip and attach a sample Test Studio project, the application log and the step failure details to your next reply. I will analyze those details and try to advise your further.
  • Does this issue reproduce on a specific page only and is it publicly accessible for me to test? You can also try different browsers, like Chrome, Firefox and Internet Explorer and let me know what happens.

It seems to me that a browser refresh will not help, if the page is not loading in the first place, as per my understanding. You can, however, use the Wait For URL step and allow some additional time for the page to load.

I am looking forward to hearing from you.

Regards,
Plamen Mitrev
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Tim
Top achievements
Rank 1
answered on 22 Nov 2019, 04:31 PM
Sorry for the delayed reply.  3rd party testing environment been down all day and therefore unable to replicate.  I will record the steps and provide scripts on Monday, but please be aware that you will not be able to run as IP controlled access to the 3rd party sites.
0
Plamen Mitrev
Telerik team
answered on 27 Nov 2019, 06:43 AM

Hi Tim,

I am curious to know if that issue is reproduced against other publicly accessible pages like https://www.bing.com. If that is the case, please share a sample test as well and I will try to reproduce it.

Please take you time to gather the requested resources along with a sample Test Studio project that I can investigate. Even though I will not be able to load the page on my end, I will be able to explore it.

Regards,
Plamen Mitrev
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Tim
Top achievements
Rank 1
answered on 16 Dec 2019, 02:47 PM
This can now be closed as it was an issue with one of test environments.
0
Plamen Mitrev
Telerik team
answered on 16 Dec 2019, 03:21 PM

Hello Tim,

I am happy to know that the issue is resolved and you can continue with the test automation.

I will proceed to close this forum thread, as you requested. Please do not hesitate to contact us again, if you need any help.

Regards,
Plamen Mitrev
Progress Telerik

 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Tim
Top achievements
Rank 1
Answers by
Plamen Mitrev
Telerik team
Tim
Top achievements
Rank 1
Tim
Top achievements
Rank 1
Share this question
or