This is a migrated thread and some comments may be shown as answers.

Recorder doesn't work when running to specific test step

3 Answers 32 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Bennett
Top achievements
Rank 1
Bennett asked on 19 Mar 2014, 02:30 PM
I have recorded a test plan in IE9 with no problem. However, after I close the browser session, I can't connect to the recorder when right clicking on a test step then selecting Run>To Here. It will run through the selected test step, but it will not connect to the recorder after it has reached this step. I looked at some of the troubleshooting steps for not being able to connect to the Recorder, but none of the recommendations seem to address my issue. Any help would be greatly appreciated!

3 Answers, 1 is accepted

Sort by
0
Ivaylo
Telerik team
answered on 24 Mar 2014, 01:01 PM
Hello  Bennett,

Please excuse me for the delayed reply. 
I am sorry to hear you are experiencing this issue. I will need you to provide me with the application log in order to investigate this further. What I want you to do is go and clear the log, then reproduce the behavior described and attach the generated application log so I can take a look.
It would be great if you can provide me with the test in question so I can reproduce this behavior on my end, of course if I have access to the tested application.
A short video demonstration also would be quite helpful, you can use Jing in order to record your video.

Looking forward to hearing from you with more details.

Regards,
Ivaylo
Telerik
 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Bennett
Top achievements
Rank 1
answered on 11 Apr 2014, 12:12 PM
Hi Ivaylo,

I apologize for the delay in my response. I had to verify some security concerns about potentially sending the application log.

As it turns out, I think I may have solved the problem. The Run to Here function doesn't always break - it only doesn't connect to the Recorder when the step to which I am running loads a PDF (I found some language that Recorder doesn't support/record PDFs). Does this sound right? Would the Recorder be unable to connect due to this fact?

Thanks,
Bennett
0
Ivaylo
Telerik team
answered on 15 Apr 2014, 10:57 AM
Hello Bennett,

Thank you for your update.
Yes you figured it out correctly. PDF is not supported by Test Studio so I assume this behavior is quite expected.

Thank you for your understanding regarding this matter. I am closing this case as resolved now.

Regards,
Ivaylo
Telerik
 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Bennett
Top achievements
Rank 1
Answers by
Ivaylo
Telerik team
Bennett
Top achievements
Rank 1
Share this question
or