number of result step is more than actual step number

4 posts, 0 answers
  1. Kevin
    Kevin avatar
    7 posts
    Member since:
    Nov 2011

    Posted 11 Nov 2011 Link to this post

    Hi,
    When i analyzed test results on test studio, i found that number of result step is not same with the actual step number, in one of my test case, it had 51 script steps, but  it displayed more than 51 in result, and the result from script step 52 is not executed. the see my attachment.
  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 11 Nov 2011 Link to this post

    Hello Kevin,

    I'm sorry you are experiencing this problem.

    We had a bug before where some deleted steps are ran during execution causing the test to fail. Which version of Test Studio you are using?

    If you restart Test Studio and open the test in question (NavBarDisclaimerVerification) do you see these ghost steps? If you do, just delete them again and the problem will disappear. If this is the issue you are facing, it appears seemingly randomly and will be able to fix it completely once we have a reliable reproduction steps. 

    Hope to hear from you soon!

    All the best,
    Plamen
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Kevin
    Kevin avatar
    7 posts
    Member since:
    Nov 2011

    Posted 13 Nov 2011 Link to this post

    Hi,
    My version of Test Studio is 2011.1.502.0, i tried to restart the test studio, and open script NavBarDisclaimerVerification, there was no ghost steps, acutally, ghost steps did not display before i restart it. but now, it can be executed successfully. i think it maybe appear randomly as you said.
  4. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 15 Nov 2011 Link to this post

    Hello Kevin,

    I'm glad to hear you are running your tests again.

    We think this bug should be fixed in our latest internal build. So my advice to you is to consider the option to upgrade. The build is available on our website. The latest version 2011.2.1108 includes a LOT of new features and bug fixes versus the 2011.1.502 version you currently have installed. 

    All the best,
    Plamen
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top