lost a scheduled list

6 posts, 0 answers
  1. Simona
    Simona avatar
    12 posts
    Member since:
    Sep 2012

    Posted 25 Jan 2013 Link to this post

    Hi Team,

    I scheduled a list with 5 tests wich I have ran them before succesfully - the scheduled list start running after few minutes form schedule time (seen it when it started) - after run stopped I've reload from server the results but no list show up(fail or pass) - seems it disappeared  - schedule server and execution server are set on same machine. 
    I've looked in logs file and I found this exception:

    1317 1/25/2013 7:56:54 AM Information Run Result Save Fail:    at ArtOfTest.Common.Serialization.XmlStore.ReadDataMemberProperties(Object obj, XmlElement root, XmlStoreNode store, IEnumerable`1 knownTypes)
       at ArtOfTest.Common.Serialization.XmlStoreNode.ReconstituteObject(XmlElement element, Type expectedType, Type serializedType, String collectionItemTag)
       at ArtOfTest.Common.Serialization.XmlStoreNode.GetValue[T](String name, String collectionItemTag)
       at ArtOfTest.Common.Serialization.XmlStoreNode.GetValue[T](String name)
       at ArtOfTest.Common.Design.Exceptions.ElementFindException.ArtOfTest.Common.Serialization.IXmlPersistable.LoadFrom(XmlStoreNode store)
       at ArtOfTest.Common.Serialization.XmlStoreNode.ReconstituteObject(XmlElement element, Type expectedType, Type serializedType, String collectionItemTag)
       at ArtOfTest.Common.Serialization.XmlStoreNode.GetValue[T](String name, String collectionItemTag)
       at ArtOfTest.Common.Serialization.XmlStoreNode.GetValue[T](String name)
       at ArtOfTest.WebAii.Design.AutomationStepResult.get_Exception()
       at ArtOfTest.WebAii.Design.Execution.TestResult.AddStepResult(AutomationStepResult stepResult, Boolean appendMessage)
       at ArtOfTest.WebAii.Design.Execution.TestResult.<>c__DisplayClass1.<RecalculateStepResults>b__0(AutomationStepResult x)
       at System.Collections.Generic.List`1.ForEach(Action`1 action)
       at ArtOfTest.WebAii.Design.Execution.TestResult.RecalculateStepResults(Boolean isExecution)
       at ArtOfTest.WebAii.Design.Execution.RunResult.<get_TestResults>b__0(TestResult tR)
       at System.Collections.Generic.List`1.ForEach(Action`1 action)
       at ArtOfTest.WebAii.Design.Execution.RunResult.get_TestResults()
       at Telerik.TestStudio.Scheduling.WindowsService.ObjectParsing.ObjectParser.ParseToDB(RunResult runResult)
       at Telerik.TestStudio.Scheduling.WindowsService.ScheduleManager.PublishResult(RunResult runResult, Machine machine, Guid projectId, String& error)


    Thanks,
    Best regards,
    Simona

  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 28 Jan 2013 Link to this post

    Hi Simona,

    I am sorry to hear you are experiencing this problem. Please try restarting the Telerik TestStudio Scheduling Service, this can sometimes fix issues like this.

    If it still doesn't work, please provide the .aiiresult files in question. They should be in your project Results folder. Once we have these files, we should be able to find out what is causing the problem and fix it.

    Kind regards,
    Plamen
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  3. Simona
    Simona avatar
    12 posts
    Member since:
    Sep 2012

    Posted 29 Jan 2013 Link to this post

    Hi Plamen,

    I've tried that and the list is no more there. If I scheduled again the list worked properly.
    The problem is that this behaviour happens very often with more of my test lists. I scheduled them - start running and when reload the results they no longer exist. Some of my list run properly and some disappear. Shouldn't be there even if they don't run successfully?

    Thanks,
    Best regards,
    Simona
  4. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 30 Jan 2013 Link to this post

    Hello Simona,

    Yes, the result should be there even if the Test List run is unsuccessful. In order to help you with this issue please go to your project "Results" folder, locate the .aiiresult files generated after the execution and send that to us in a zip file. Thanks for providing the info we need to best assist you. 

    All the best,
    Plamen
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  5. Simona
    Simona avatar
    12 posts
    Member since:
    Sep 2012

    Posted 05 Feb 2013 Link to this post

    Hi Plamen,

    I can't find the list .aiiresult file in the project results folder. 
    The good thing is that after I restarted Test Studio Scheduling Service didn't happen anymore to lose schedule lists.

    Thanks for your help.
    Best regards,
    Simona
  6. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 05 Feb 2013 Link to this post

    Hi Simona,

    I'm glad to hear you're not experiencing the issue after restarting the Scheduling Service. If the same issue appear again I recommend to upgrade to our latest internal build(2012.2.1317), which includes fixes for some Serialization issues. You can download it from your Telerik.com account here: Public URL.  

    Regards,
    Plamen
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top