This is a migrated thread and some comments may be shown as answers.

IE crashed while playing a test

3 Answers 39 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Adriane
Top achievements
Rank 1
Adriane asked on 06 Jun 2012, 04:13 PM
The Internet Explorer is crashing if I play a special test.

I know I played it before without problems, but a cmd window occurs now every time I start it and an overlay popup is blocking this, so I cannot copy the failure message.
But I attached a screengrab.
Maybe you can see something in the image, or tell me some cases when this is happening, so that I can check this?

For information if you need it I have a silverlight application.

Best regards,
Adriane

 

3 Answers, 1 is accepted

Sort by
0
Plamen
Telerik team
answered on 08 Jun 2012, 12:12 PM
Hello Adriane,

I am sorry to hear you are experiencing such problem. Unfortunately we cannot troubleshoot this error from the screenshot information alone. Please see this page for the additional information you can provide so we can get to the bottom of this. An Application Log will likely be useful.

The best approach is to provide us a test (preferably written against a public site) that demonstrates the issue. If the issue is specific to your environment and not replicated on another machine, then please provide as many details on that environment as possible.

Greetings,
Plamen
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Adriane
Top achievements
Rank 1
answered on 08 Jun 2012, 01:53 PM
Hi Plamen,

I had it again and want to give you all information I can about this.
Attached is the logfile with only the one execution and the error messages.

I have a local silverlight application, so I cannot show it to you with a public site.
But some tests work, so maybe there is a problem with recording the test, that one step is not correct recorded?

I also put you a overview of the steps.
Short description:
I cleared out the database and insert new 4 entries in there, login to the special site, so that I can search on the local side called MediaCenter and find in general 4 entries. In the silverlight page I can find a tab vor an expertsearch with more options. I want to click to this and then do some special steps.
I think somehow the tab is not found? Because it seems, that step 14 is the one to abort.
I also attached a screen from MediaCenter, so that you can imagine this better.

I hope there is something in the log or something that you can tell me to try out.

Best regards,
Adriane


0
Plamen
Telerik team
answered on 13 Jun 2012, 11:13 AM
Hello Adriane,

Thank you for providing the trace log. The issue is with the SilverlightApp element that the SearchTabControlTabcontrol resides under. This must be something that changed in your app. Like HTML Frames, Test Studio must locate the SilverlightApp on the page first before it can find its containing elements.

Try to re-record the step against the TabControl, this should update the find settings for the SilverlightApp element(see screenshot). Also, please increase the Silverlight Connect Timeout in Project Settings > Recording Options.

Regards,
Plamen
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
Tags
General Discussions
Asked by
Adriane
Top achievements
Rank 1
Answers by
Plamen
Telerik team
Adriane
Top achievements
Rank 1
Share this question
or