hover over highlighting missing in popup/model dialog windows.

6 posts, 0 answers
  1. wish
    wish avatar
    43 posts
    Member since:
    Aug 2011

    Posted 05 Aug 2011 Link to this post

    Hi,

    I have two issues:

    1.Hover over highlighting are missing on popup/model dialog windows...how i can get them on these?
    2.i have created around 10 dropdowns with no name attributes on SL app...when executing the recorded test case on these dropdowns (selected items), everytime only first  dropdown is identified...
    upon checking the DOM explorer, found that since no name attributes are set for these dropdowns, defualt names are setted...so very first occurence of control caught everytime...
    ...how can i avoid this issue by identifying this element...correctly...
    PFA having default names for drop downs...

  2. wish
    wish avatar
    43 posts
    Member since:
    Aug 2011

    Posted 05 Aug 2011 Link to this post

    any one...pls help me here....

    hi telerik,

    can you pls help me here...
  3. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 10 Aug 2011 Link to this post

    Hello Wish,

    I am sorry you are running into this problem. Highlighting should automatically work in popup/model dialog windows. There isn't anything special you need to do to make this work right. Is there a public website I can connect to to study this problem? One thing you can try which occasionally helps is to click the Reconfigure Recorder button as shown in the attached screen shot. This reconnects the recorder to the browser in the event it was somehow disconnected.

    For your second issue, the recorder is supposed to automatically detect there are duplicate names and not use them. It instead will generate and use a special XAML path to correctly identify the target element. Here too I need to be able to see and study this problem first hand in order to understand why we're not recording correctly.

    Regards,
    Cody
    the Telerik team
    Vote for Telerik Test Studio at the Annual Automation Honors Voting!
  4. wish
    wish avatar
    43 posts
    Member since:
    Aug 2011

    Posted 12 Aug 2011 Link to this post

    Hi Cody,

    Please find the attached screen shot for second issue description.

    Beside is a form having number of controls except division dropdown are unnamed.(I checked the xaml file of this form, except division, remaining are unnamed)

    Please see the DOM explorer which shows default names generated, because it has no name attribute defined except for division dropdown.

    Description scenario 1:

    First I started recording the test case, and I selected all dropdown values and click save.

    When am executing the recorded test case, till division dropdown selection worked fine, but from gender dropdown always for the steps recorded for other dropdowns selection is going on gender because all the default names are same, hence first catch of dropdown is selecting and finally click save results test case fail, because no selections other dropdown.

    Please help with the solution.

    Pls check once and let me know any other suggestions.

    Thanks,
    Hari Wish

  5. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 12 Aug 2011 Link to this post

    Hi Wish,

    How did your developers get duplicate names in there? We tried (we're know only basic Silverlight programming) but were unsuccessful at recreating a similar looking DOM (I can get duplication automation ID's, but not Names). Can you send us a sample Silverlight project that replicates this behavior for us to study? Or can we directly access your application to study this problem?

    Regards,
    Cody
    the Telerik team
    Vote for Telerik Test Studio at the Annual Automation Honors Voting!
  6. wish
    wish avatar
    43 posts
    Member since:
    Aug 2011

    Posted 17 Aug 2011 Link to this post

    ok cody...i will send sample app..
Back to Top