This is a migrated thread and some comments may be shown as answers.

Functional tests are inconsistent

1 Answer 17 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Janet
Top achievements
Rank 1
Janet asked on 24 Jun 2013, 03:39 PM
Hi Team,

I'm currently running a functional test on my website that has login, add a patient, add a claim and make a payment for that patient. The test is very inconsistent every time I run it. Sometimes the test clicks on the add button perfectly fine, other times it clicks the button right next to it even though i have set it to left click on that specific point. Other times it will click on the submit button but it won't actually click on it, if that makes any sense. The test is not data bound to anything or is running over and over again. I simply click run once and sometimes it will run perfectly fine and other times it clicks on the wrong button. 

1 Answer, 1 is accepted

Sort by
0
Rodney
Telerik team
answered on 26 Jun 2013, 10:24 PM
Hi Janet,

There could be a number of factors causing your tests to run inconsistently but to accurately help you find the cause of your issue, we'll need more information about your test scenario. Please provide your test failure logs (there should be 5 files in the export). You can export these to file from the failure tab of your test and add them to a .zip. 

Once we have your failure logs we can tell you what needs to be done to prevent the failures. 

Regards,
Rodney
Telerik
Free summer webinars on advanced web automation tactics hosted by Jim Holmes & Adam Goucher.
Reserve your seat today!
Tags
General Discussions
Asked by
Janet
Top achievements
Rank 1
Answers by
Rodney
Telerik team
Share this question
or