This is a migrated thread and some comments may be shown as answers.

FindLogic Ignores Recoding Element Added to Repository

1 Answer 9 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Kimberlee
Top achievements
Rank 1
Kimberlee asked on 20 Feb 2014, 12:51 AM
I've run into this issue a few times in particular with Continue Buttons and Radio Dials that are javascript based. Recording these elements, whether they are added to the repository beforehand or after are not being recorded with the custom name given. Instead, it gives it a generic name (continuespan, continuespan(), span0 , etc) which sometimes causing the test to fail on subsequent executions.

I noticed that the FindLogic is picking up the div id and tagindex. The problem I've noticed is that in other tests using the same webpage but with different factors, the span number will change. No matter what I name these buttons to when recording the test, it is not saved in the test and does not appear anywhere when editing the element.

What is the best solution to this problem?

Attached screenshots for reference.

1 Answer, 1 is accepted

Sort by
0
Cody
Telerik team
answered on 21 Feb 2014, 02:30 PM
Hi,

This is a duplicate of your other forum post. We will respond there.

Regards,
Cody
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Kimberlee
Top achievements
Rank 1
Answers by
Cody
Telerik team
Share this question
or