This is a migrated thread and some comments may be shown as answers.

Failure Running a Test List

2 Answers 44 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Top Gun
Top achievements
Rank 1
Top Gun asked on 17 Jul 2012, 09:34 PM

I have created a simple automated test.  The test just opens Internet Explorer.  Navigates to www.google.com.  In the Google searchbox, it enters Telerik. Then it selects the Telerik result link and the Telerik website appears.  The Test runs fine (On its own).  The problem occurs when I run the test in a Test List.  When I run the Test List, it navigates to the Google  website.  But it fails to type in Telerik.  Error Message: ArtOfTest.Common.Design.Exceptions.ExecutionException: Unexpected dialog:  My test runs just fine on its own but it does not run in a Test List.  It is the only test in my Test List.  Please let me know what I am doing wrong.

2 Answers, 1 is accepted

Sort by
0
Plamen
Telerik team
answered on 18 Jul 2012, 07:13 AM
Hi Top Gun,

The unexpected dialog error means that Test Studio encountered a dialog during the TestList run and then failed the test because of that. Check out this article detailing the situation. I recommend selecting the 'UnexpectedDialogAction' property to 'HandleAndContinue' in your case.

All the best,
Plamen
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Top Gun
Top achievements
Rank 1
answered on 18 Jul 2012, 02:20 PM
Great!  That worked.  Thank you.
Tags
General Discussions
Asked by
Top Gun
Top achievements
Rank 1
Answers by
Plamen
Telerik team
Top Gun
Top achievements
Rank 1
Share this question
or