This is a migrated thread and some comments may be shown as answers.

Exception occurs when execute test from TestStudio

1 Answer 50 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Vitaliy
Top achievements
Rank 1
Vitaliy asked on 08 Oct 2012, 10:24 AM
Hi,

I'm using trial version 2012.2.920.0 of TestStudio and when i start to execute my test  - the execution has been failed with the following exception in log file:

'10/8/2012 1:23:43 PM' - Using .Net Runtime version: '4.0.30319.17929' for tests execution.'10/8/2012 1:23:43 PM' - Starting execution....'10/8/2012 1:23:43 PM' - Detected a Silverlight Test. Setting EnableSilverlight=True'10/8/2012 1:23:44 PM' - Failure detected during execution. Details:------------------------------------------------------------'10/8/2012 1:23:44 PM' - ArtOfTest.WebAii.Exceptions.ExecuteCommandException: ExecuteCommand failed!BrowserCommand (Type:'Information',Info:'IsReady',Action:'NotSet',Target:'null',Data:'',ClientId:'Client_00e508d3-d197-47d4-88ea-7150208bf338',HasFrames:'False',FramesInfo:'',TargetFrameIndex:'-1',InError:'False',Response:'')InnerException: System.NullReferenceException: Object reference not set to an instance of an object. at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request) ---> System.NullReferenceException: Object reference not set to an instance of an object. at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request) --- End of inner exception stack trace --- at ArtOfTest.WebAii.Core.Browser.ExecuteCommandInternal(BrowserCommand request) at ArtOfTest.WebAii.Core.Browser.ExecuteCommand(BrowserCommand request, Boolean performDomRefresh, Boolean waitUntilReady) at ArtOfTest.WebAii.Core.Browser.IsReady() at ArtOfTest.WebAii.Core.Browser.WaitUntilReady() at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle, String arguments) at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(ProcessWindowStyle windowStyle, String arguments) at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.InitializeWeb(ExecutionEngineCreateParams initParams) at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.CreateAndInitializeEngine(Test test, ExecutionEngineCreateParams cp) at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(ExecuteTestCommand command)------------------------------------------------------------'10/8/2012 1:23:45 PM' - Test completed!

1 Answer, 1 is accepted

Sort by
0
Mario
Telerik team
answered on 10 Oct 2012, 09:36 PM
Hello Vitaliy,

Thank you for contacting Telerik Support.

Would you be able to provide me with a copy of your test so that I may reproduce this issue locally. Additionally a Jing video of a manual demonstration of your application showing the features that are tested may also help me to better understand your environment and what is happening.

Let me know if you require 

Regards,
Mario
the Telerik team
Are you enjoying Test Studio? We’d appreciate your vote in the ATI automation awards.
Vote now
Tags
General Discussions
Asked by
Vitaliy
Top achievements
Rank 1
Answers by
Mario
Telerik team
Share this question
or