This is a migrated thread and some comments may be shown as answers.

Error for Reporter and Agents in load testing

1 Answer 24 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Morgan
Top achievements
Rank 1
Morgan asked on 14 Jun 2013, 06:53 AM
I'm trying to using your load test. But I can't run the test because the Reporter and the Agents still red.
Here's the error for both of them:
"No Reporter has contacted the Controller" and "No Agents has contacted the Controller". I don't know why I got this error.

Can you please kindly help me?

This is my log:
[06/14 13:45:24,Telerik.TestStudio.Services.exe(716:14),Load] LoadReporterService.PollForController() : Unable to notify controller.
[06/14 13:45:24,Telerik.TestStudio.Services.exe(716:4),Load] LoadAgentService.PollForController() : Unable to talk to the controller.
[06/14 13:46:44,Telerik.TestStudio.Services.exe(716:41)] First trace message from pool unnamed thread (managed ID = 41, native ID = 2596).
[06/14 13:46:44,Telerik.TestStudio.Services.exe(716:41),Load] LoadReporterService.PollForController() : Notifying controller that this reporter is active...
[06/14 13:46:44,Telerik.TestStudio.Services.exe(716:24)] First trace message from pool unnamed thread (managed ID = 24, native ID = 7536).
[06/14 13:46:44,Telerik.TestStudio.Services.exe(716:24),Load] LoadAgentService.PollForController() : Notifying controller that this agent is active...
[06/14 13:46:47,Telerik.TestStudio.Services.exe(716:41),Load] LoadReporterService.PollForController() : Unable to notify controller.
[06/14 13:46:47,Telerik.TestStudio.Services.exe(716:24),Load] LoadAgentService.PollForController() : Unable to talk to the controller.
[06/14 13:48:07,Telerik.TestStudio.Services.exe(716:7)] First trace message from pool unnamed thread (managed ID = 7, native ID = 812).
[06/14 13:48:07,Telerik.TestStudio.Services.exe(716:7),Load] LoadAgentService.PollForController() : Notifying controller that this agent is active...
[06/14 13:48:07,Telerik.TestStudio.Services.exe(716:38)] First trace message from pool unnamed thread (managed ID = 38, native ID = 3492).
[06/14 13:48:07,Telerik.TestStudio.Services.exe(716:38),Load] LoadReporterService.PollForController() : Notifying controller that this reporter is active...
[06/14 13:48:09,Telerik.TestStudio.Services.exe(716:38),Load] LoadReporterService.PollForController() : Unable to notify controller.
[06/14 13:48:09,Telerik.TestStudio.Services.exe(716:7),Load] LoadAgentService.PollForController() : Unable to talk to the controller.
 

1 Answer, 1 is accepted

Sort by
0
Velin Koychev
Telerik team
answered on 14 Jun 2013, 12:32 PM
Hi Morgan,

First thing you should check is whether you have configured the load testing services correctly. Please check out this article. Check the database connection. 

One of the possible reasons for your issue might be because the SQL instance is not reachable for network reasons, or you don't have permissions with the provided user to create/connect to the DB. You could try to temporary disable any firewall and antivirus software on your computer, to see if this helps. 


The other possible problem for the services not being able to connect is that the port they are using is taken by another application on the system, without your knowledge. To check that you can use some free TCPIpView software to check all the ports on your system when services are stopped and when they are started, to see if some of the ports (controller or reporter mainly) are not taken by another program.

Please tell us if either of these suggestions helped you solve the problem you are experiencing. If you continue to receive this issue, please send us the service log.

Regards,
Velin Koychev
Telerik
Free summer webinars on advanced web automation tactics hosted by Jim Holmes & Adam Goucher.
Reserve your seat today!
Tags
General Discussions
Asked by
Morgan
Top achievements
Rank 1
Answers by
Velin Koychev
Telerik team
Share this question
or