Elements cannot be found during execution

3 posts, 0 answers
  1. Mark
    Mark avatar
    10 posts
    Member since:
    Dec 2006

    Posted 20 Jul 2011 Link to this post

    I performed the following steps:
    1. Recorded a script.
    2. Checked element identification logic to ensure that the identification logic did not include any dynamically created ID's & that elements were unique.
    3. Ran the script.
    4. Script failed because several elements that had been recorded could no longer be found on screen.
    5. Used Find Element - Live Action to review element definitons and validate those definitons. The identification logic was fine, but validation failed
    6. Opened the page where the elements were located, clicked on the elements to find out more info about them - changed identification information in Telerik.
    7. Attempted to validate elements with new definitions - failed again.


    Note: all of the elements that I am having this issue with are found on 1 frame.  I've tried identifying the item with the default frame inforamtion given to me by Telerik and I've tried changing the frame definition, but nothing I'm doing seems to be working.  Other frames are identified exactly the same as the problem frame and the system is having no problem identifying elements on those frames, so at this point I'm out of ideas.  Suggestions would be appreciated.

  2. Anthony
    Admin
    Anthony avatar
    19 posts

    Posted 22 Jul 2011 Link to this post

    Hello Mark,

    I dealt with another customer earlier in the week who also had an issue regarding an element find failure within a frame. I logged a bug and the fix is scheduled to be included in the next internal build.

    If you continue to have difficulty on the new version, we'll move forward with more detail and issue reproduction.

    Greetings,
    Anthony
    the Telerik team
    Register today for a live 'What's New in Test Studio R1 2011 SP2' event on Tuesday, July 19 at 2pm EST!

    Have you looked at the new Online User Guide for Telerik Test Studio?
  3. Mark
    Mark avatar
    10 posts
    Member since:
    Dec 2006

    Posted 22 Jul 2011 Link to this post

    Thank you
Back to Top