Control does not match FindExpression

4 posts, 0 answers
  1. Floyd
    Floyd avatar
    2 posts
    Member since:
    Dec 2011

    Posted 21 Dec 2012 Link to this post

    I have recorded a test that selects an element in a tree view.  After recording it, I try to run the test and I get the following error message:
    ----------------------------------------------
    Failure Information:
    ~~~~~~~~~~~~~~~
    Invalid control '[Element: 'li:13']'.  Control does not match FindExpression '[class 'Contains' RadTreeView RadTreeView] AND [TagName 'Exact' div]'
    InnerException:
    System.ArgumentException: Invalid control '[Element: 'li:13']'.  Control does not match FindExpression '[class 'Contains' RadTreeView RadTreeView] AND [TagName 'Exact' div]'
       at ArtOfTest.WebAii.Controls.Control.CreateInstance[TControl](Element e, Boolean throwIfNull)
       at Telerik.WebAii.Design.Translators.Html.TreeView.RadTreeViewActionDescriptor.Execute(Browser browser)
       at ArtOfTest.WebAii.Design.Extensibility.HtmlActionDescriptor.Execute(IAutomationHost autoHost)
       at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)
    --------------------------------------------------
    I am new at this, and I have tried to tweak the the command, but I continue to get this error. 

    What is causing this problem?  What should I change?
    What other information do I need to post that will help diagnose the problem.?
  2. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 24 Dec 2012 Link to this post

    Hi Floyd,

    I'm sorry to find you're running into a problem with recording/playback.

    This sounds like either an incompatible RadControls with the Test Studio Translators (could be quite an old RadControls version running with the application) or a problem very specific to the application under test.

    I checked your downloads history and noticed you are running a version of the product from July 2012. Is it possible for you to upgrade to the latest December release and see if that helps (you can find the full list of release notes here)? As stated in the documentation any updates in RadControls are being taken into account with next Test Studio releases so that those Translators are compatible with the latest from Telerik RadControls.

    Another option could be to try disabling the RadTreeView for ASP.NET AJAX translator. You need to find it in the list and disable it by unchecking the corresponding check box, then re-record the selection step.

    Please let us know if this helps or if you need further assistance.

    Regards,
    Konstantin Petkov
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  3. Alex
    Alex avatar
    1 posts
    Member since:
    Mar 2019

    Posted 14 Mar Link to this post

    Im having the same issue with this kendo-numerictextbox

    ArtOfTest.Common.Design.Exceptions.ExecutionException: Invalid control '[Element: 'input:3' (id=input-step)]'.  Control does not match FindExpression '[tagname 'Contains' kendo-numerictextbox]' ---> System.ArgumentException: Invalid control '[Element: 'input:3' (id=input-step)]'.  Control does not match FindExpression '[tagname 'Contains' kendo-numerictextbox]'
       at ArtOfTest.WebAii.Controls.Control.CreateInstance[TControl](Element e, Boolean throwIfNull)
       at Telerik.TestStudio.Translators.KendoUI.Angular.Input.ActionDescriptors.NumericBoxTypeActionDescriptor.Execute(Browser browser)
       at ArtOfTest.WebAii.Design.Extensibility.HtmlActionDescriptor.Execute(IAutomationHost autoHost)
       at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.ExecuteStep(Int32 order)
       --- End of inner exception stack trace ---

  4. Elena
    Admin
    Elena avatar
    1144 posts

    Posted 19 Mar Link to this post

    Hello Alex,

    Thank you for contacting us. Please, note that the issue, you are addressing, dates back few years ago so the provided solution certainly cannot be applied. 

    However, we can explore what is causing the current error you have encountered. Based on the error message it seems that target element is an input control but you have used filter to locate this tagname 'Contains' kendo-numerictextbox. Can you please verify what is the find logic for this element and try to modify the filters using the suggestions when in active recording session. Probably the kendo-numerictextbox is the class of the input control. 

    In case the above is still not helping you to find a solution for the failing test, I will appreciate if you collect the step failure details once the test finishes. You can use the Export button to get a zip file with the details, which can be attached to this thread. These will help me explore further how possibly the element can be located on the page. 

    Please, let me know in case of any further questions. 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top