This is a migrated thread and some comments may be shown as answers.

ContinueOnFailure=False

4 Answers 22 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Susmita
Top achievements
Rank 1
Susmita asked on 11 Mar 2014, 10:23 AM
Hi 
    I am new to telerik test studio and trying out the trial version.just to get the working of the element menu I tried to record a web test....
1. navigated to www.google.com
2.once again searched for google 
3.when all the links appeared tried to verify the text using build verifications on the first link

when I played it , the test  got aborted with this error message in the log:
"Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution."

I have even tried to insert wait for exits and also used break point....but it does'nt help

4 Answers, 1 is accepted

Sort by
0
Boyan Boev
Telerik team
answered on 11 Mar 2014, 02:20 PM
Hello Susmita,

Thank you for contacting us.

What you see is a part of the execution log. This just means that some of the step failed and since ContinueOnFailure property is set to False the entire test failed.

In order to investigate this please send us the entire execution log.

You can send us also the test project.

Hope to hear from you soon.

Regards,
Boyan Boev
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
0
Susmita
Top achievements
Rank 1
answered on 13 Mar 2014, 09:18 AM
The execution log is:


Overall Result: Fail
------------------------------------------------------------
'13-03-2014 14:45:47' - Using .Net Runtime version: '4.0.30319.233' for test execution. Build version is '2013.2.1327.0'.
'13-03-2014 14:45:47' - Starting execution....
------------------------------------------------------------
------------------------------------------------------------
'13-03-2014 14:45:51' - Using 'InternetExplorer' version '8.0' as default browser. 
'13-03-2014 14:45:53' - 'Pass' : 1. Navigate to : 'http://www.google.com/'
'13-03-2014 14:45:54' - 'Pass' : 2. Click 'TableCell'
'13-03-2014 14:45:54' - 'Pass' : 3. Enter text 'google' in 'QText'
'13-03-2014 14:45:54' - 'Pass' : 4. Click 'BtnGSubmit'
'13-03-2014 14:46:25' - 'Fail' : 5. Verify 'TextContent' 'Contains' 'Google' on 'GoogleBTag'
------------------------------------------------------------
Failure Information: 
~~~~~~~~~~~~~~~
Unable to locate element. Details: Attempting to find [Html] element using 
Find logic 
 (Html): [id 'Exact' ires][tagIndex 'Exact' b:0]

Unable to locate element. Search failed!

Learn more about finding elements here:
http://www.telerik.com/automated-testing-tools/support/documentation/user-guide/troubleshooting_guide/test-execution-problems/unable-to-locate-element.aspx
------------------------------------------------------------
'13-03-2014 14:46:25' - Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution.
------------------------------------------------------------
'13-03-2014 14:46:25' - Overall Result: Fail
'13-03-2014 14:46:25' - Duration: [0 min: 34 sec: 314 msec]
------------------------------------------------------------
'13-03-2014 14:46:26' - Test completed!
0
Susmita
Top achievements
Rank 1
answered on 13 Mar 2014, 09:22 AM
One more thing

I created a new script with same steps but this time I used www.bing.com for navigation.....and when played it successfully runs

Overall Result: Pass
------------------------------------------------------------
'13-03-2014 14:49:28' - Using .Net Runtime version: '4.0.30319.233' for test execution. Build version is '2013.2.1327.0'.
'13-03-2014 14:49:28' - Starting execution....
------------------------------------------------------------
------------------------------------------------------------
'13-03-2014 14:49:33' - Using 'InternetExplorer' version '8.0' as default browser. 
'13-03-2014 14:49:34' - 'Pass' : 1. Navigate to : 'http://www.bing.com/'
'13-03-2014 14:49:37' - 'Pass' : 2. Enter text 'google' in 'SbFormQText'
'13-03-2014 14:49:39' - 'Pass' : 3. Click 'SbFormGoSubmit'
'13-03-2014 14:49:40' - 'Pass' : 4. Verify 'TextContent' 'Contains' 'Google' on 'GoogleStrongTag'
------------------------------------------------------------
'13-03-2014 14:49:40' - Overall Result: Pass
'13-03-2014 14:49:40' - Duration: [0 min: 6 sec: 928 msec]
------------------------------------------------------------
'13-03-2014 14:49:40' - Test completed!
0
Accepted
Boyan Boev
Telerik team
answered on 18 Mar 2014, 08:32 AM
Hello Susmita,

The test failed against Google site because it changes its tagindexes dynamically and you are using it in your find expression.

We recommend to use unique attributes in your find logic.

Let me know if you need further assistance.

Regards,
Boyan Boev
Telerik
 
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Susmita
Top achievements
Rank 1
Answers by
Boyan Boev
Telerik team
Susmita
Top achievements
Rank 1
Share this question
or