This is a migrated thread and some comments may be shown as answers.

Compilation Error : The code generator failed to generate dll

3 Answers 55 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Nithya
Top achievements
Rank 1
Veteran
Nithya asked on 08 Jun 2020, 08:06 AM

Hi , 

 

I was working in my Project. It was going ok. Suddenly, while compiling I got this error. I am not sure how to fix this and what caused this error. 

Could you please help me to fix this.

Note : When I open my old copy of the project which is placed in different location. There is no such errror.

Only with the particular project, I got this error. I feel something should be crashed when I was trying some steps in the scripts.

 

10:00:46 'ERROR' > error The code provider failed to generate the .dll, please check the output bellow.: C:\Program Files (x86)\Progress\Test Studio\Bin> "C:\Windows\Microsoft.NET\Framework\v4.0.30319\vbc.exe" /t:library /utf8output /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Core\v4.0_4.0.0.0__b77a5c561934e089\System.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\ArtOfTest.WebAii\v4.0_2020.1.331.0__4fd5f65be123776c\ArtOfTest.WebAii.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\ArtOfTest.WebAii.Design\v4.0_2020.1.331.0__4fc62bbc3827ab1d\ArtOfTest.WebAii.Design.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.WebAii.Controls.Html\v4.0_2020.1.331.0__528163f3e645de45\Telerik.WebAii.Controls.Html.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.WebAii.Controls.Xaml\v4.0_2020.1.331.0__528163f3e645de45\Telerik.WebAii.Controls.Xaml.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.WebAii.Controls.Xaml.Wpf\v4.0_2020.1.331.0__528163f3e645de45\Telerik.WebAii.Controls.Xaml.Wpf.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.TestingFramework.Controls.KendoUI\v4.0_2020.1.331.0__528163f3e645de45\Telerik.TestingFramework.Controls.KendoUI.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.TestingFramework.Controls.KendoUI.Angular\v4.0_2020.1.331.0__528163f3e645de45\Telerik.TestingFramework.Controls.KendoUI.Angular.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.TestingFramework.Controls.TelerikUI.Blazor\v4.0_2020.1.331.0__528163f3e645de45\Telerik.TestingFramework.Controls.TelerikUI.Blazor.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Telerik.TestStudio.Translators.Common\v4.0_2020.1.331.0__528163f3e645de45\Telerik.TestStudio.Translators.Common.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_32\System.Data\v4.0_4.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Windows.Forms\v4.0_4.0.0.0__b77a5c561934e089\System.Windows.Forms.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Drawing\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" 

 

Regards, 

Nithya A.

3 Answers, 1 is accepted

Sort by
0
Nithya
Top achievements
Rank 1
Veteran
answered on 08 Jun 2020, 09:04 AM

Hi Again, 

I debugged further to find out the error. Then I caught that "Imports system.windows.forms" caused the above error.

I imported "Imports system.windows.forms" , inorder to use the following code 

                         Sendkeys.SendWait("{down}") 
                         System.Threading.Thread.Sleep(1500)
                         Sendkeys.SendWait("{Enter}")

Because, if I remove that import, it says "Sendkeys is not declared"

 

Please let me know, what is wrong here ? and how should i use sendkeys ?

 

Regards, 

Nithya A.

0
Nithya
Top achievements
Rank 1
Veteran
answered on 08 Jun 2020, 09:13 AM

Sorry. Please ignore the previous reply..
I still get the error. I failed to see the failure message.

 

I mean to say, that still I get the "The code provider failed to generate the .dll," error. Please help!!

 

Regards,

Nithya A.

0
Elena
Telerik team
answered on 08 Jun 2020, 12:16 PM

Hi Nithya,

I am sorry to hear you are having troubles with the project you work on and will be happy to assist you with resolving these. 

As far as I can see the project, which cannot be compiled is located on a shared drive - is that correct? 

 If so, I suspect that the user, under which Test Studio is running, may not have sufficient permissions to write on the disk where the shared folder is. Can you, please, check this with your IT department? 

Another cross check you can perform is to copy the project on your local drive to a complete new location, on which the logged user has permissions to write. Then open the project from that location and compile it - do you get the same error?

Please, let me know if the shared suggestion helped you or we need to continue the investigation. 

I am looking forward to hearing back from you.

Regards,
Elena
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Tags
General Discussions
Asked by
Nithya
Top achievements
Rank 1
Veteran
Answers by
Nithya
Top achievements
Rank 1
Veteran
Elena
Telerik team
Share this question
or