This is a migrated thread and some comments may be shown as answers.

Cannot find html Table on IE 9

3 Answers 27 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Ha
Top achievements
Rank 1
Ha asked on 01 Aug 2012, 07:05 AM
Hi
I am finding HtmlTable on IE 9. But it is always null
I checked , table is existence at finding step
Could you help me?
Please refer attachment
Thanks

3 Answers, 1 is accepted

Sort by
0
Ivaylo
Telerik team
answered on 06 Aug 2012, 10:17 AM
Hello Ha,

Please excuse me for the delayed reply.
We will need more information in order to investigate this error. Could you please provide the code you are trying to execute and access to your application so we can proceed further. 

Looking forward to hear from you.

Kind regards,
Ivaylo
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Ha
Top achievements
Rank 1
answered on 07 Aug 2012, 06:42 AM
Hi Ivaylo
Sorry, you can not access to my system
I can provide code as attachment  to you review
Others, when I record by telerik and view Dom tree. I can not see "tr" in table
Please view attachment
Thanks so much
0
Ivaylo
Telerik team
answered on 09 Aug 2012, 11:17 AM
Hello Ha,

Thank you for your reply. 

Without having access or at least the source of your application we cannot investigate further. We tried to execute your code against a sample table and it runs without the error: System.NullReferenceException: Can't Find Items tblFunction. Here is a short video demonstrating how this is working on our side. I am also attaching my test for further references. in this ticket.
It seems you are getting the error because you are using a different table id or the id got changed for some reason. In case everything is set correctly and the problem is on our side, this might be specific issue and we still need access to your application in order to get a repro and continue investigating on our side.
Regarding the missing <tr> tag are you sure you are pointing the right table, but not an empty one? 

Once again without access or stripped down version of your application we cannot continue investigating any further.

Thank you for your understanding regarding this matter.

Regards,
Ivaylo
the Telerik team
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
Tags
General Discussions
Asked by
Ha
Top achievements
Rank 1
Answers by
Ivaylo
Telerik team
Ha
Top achievements
Rank 1
Share this question
or