Can not register execution server when it was configured as schedule server

3 posts, 0 answers
  1. Kevin
    Kevin avatar
    2 posts
    Member since:
    Oct 2011

    Posted 14 Dec 2011 Link to this post

    Hi,
    I configured one server as schedule server, now i want to use it as an execution server, then i open "Configure as Execution Server" in this server, click register, but only an output path selection window displayed, i need to select a schedule server.
    see my attachment.
  2. Plamen
    Admin
    Plamen avatar
    8 posts

    Posted 14 Dec 2011 Link to this post

    Hi Kevin,

    You already have configured Scheduling server. As a result the Execution server is now connecting to this local Scheduling server by default. This implementation is intended to make it more simple to configure your Scheduling setup. You need to manually turn off this default setting.

    First you need to locate the Scheduling configuration file on the machine in question. In should be located in:

    On Win7:
    C:\ProgramData\Telerik\Configs\Telerik.TestStudio.Scheduling.WindowsService.exe.Config

    On Win XP/Server 2003: C:\Documents and Settings\All Users\Application Data\Telerik\Configs\Telerik.TestStudio.Scheduling.WindowsService.exe.Config

    Now find and change the following setting:
    <add key="IsServerContext" value="False" />
    It should be set to "true" by default, change it to "false".
    Here's the context:

    Copy Code
    <appSettings>
    <add key="TimerElapsedTime" value="60000" />
    <add key="IsDatabaseCreated" value="True" />
    <add key="RootFolderPath" value="C:\Temp\Output" />
    <add key="IsMachineRegistered" value="False" />
    <add key="ScheduleServerUrl" value="http://DJAMBOV:8009/TestStudio/SchedulingService" />
    <add key="IsInitialConfig" value="True" />
    <add key="IsServerContext" value="False" />
    <add key="MachineId" value="026cdcf6-b879-40bd-bc20-63449f1e5ec2" />
    <add key="ResultsFolder" value="C:\Temp\RunResultsData" />
    <add key="ClientSettingsProvider.ServiceUri" value="" />
    <add key="DBVersion" value="9" />
    </appSettings>

    Best wishes, Plamen
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Kevin
    Kevin avatar
    2 posts
    Member since:
    Oct 2011

    Posted 14 Dec 2011 Link to this post

    Hi,
    it works now, thanks for your help.
Back to Top