Can't Add Data Source to Test

2 posts, 1 answers
  1. Alan
    Alan avatar
    15 posts
    Member since:
    Aug 2014

    Posted 07 Nov 2014 Link to this post

    I am trying to add a data source to one of my tests and running into a little issue. When I select an existing excel file to use as the data source, Test Studio is giving me an error that the file already exists, which implies Test Studio wants to create the file for me. But when I enter the name of a file that doesn't exist, I get an error that the file doesn't exist. It seems like I only have two choices here, enter an existing file or a non-existent file. I've tried both. Am I missing a third choice that's not readily apparent?

    The version of Test Studio I am using is version 2014.3.903.0 on a laptop running Windows 7 Enterprise SP 1.

    I've attached the following screen shots and copied the trace log below:
        Add_Data_Src_Get_File.PNG                                                             Existing excel file selected
        Create_New_Data_Src_Window.PNG                                                Create button clicked
        File_Exists_Error.PNG                                                                           Error indicating Test Studio doesn't like existing file
        Add_Data_Src_Create_File.PNG                                                        File name of non-existent file entered
        File_Does_not_Exist_Error.PNG                                                          Error indicating Test Studio wants an existing file

        Telerik Test Studio Trace Log-141107.txt (not sure how helpful this will be, as there doesn't seem to be a lot of detail at the end of the log where the messages related to adding the data source appear to be):

    [11/07 10:03:13,telerik.teststudio.exe(964:1)] First trace message from process 964: "c:\bin\telerik\test studio\bin\telerik.teststudio.exe"
    [11/07 10:03:13,telerik.teststudio.exe(964:1)] First trace message from foreground thread "Application start thread" (managed ID = 1, native ID = 2180).
    [11/07 10:03:13,telerik.teststudio.exe(964:1),Uncategorized] App.OnStartup() :
         Using: ArtOfTest.WebAii, Version=2014.3.903.0, Culture=neutral, PublicKeyToken=4fd5f65be123776c
         OS: Microsoft Windows 7 Enterprise 64-bit 6.1.7601 Service Pack 1
         .NET version: 4.0.30319.18063
    [11/07 10:03:17,Telerik.TestStudio.Scheduling.Client.exe(2600:1)] First trace message from process 2600: "C:\bin\Telerik\Test Studio\Bin\Telerik.TestStudio.Scheduling.Client.exe" /EmbedExecutionManager /EmbedProcessManager
    [11/07 10:03:17,Telerik.TestStudio.Scheduling.Client.exe(2600:1)] First trace message from foreground unnamed thread (managed ID = 1, native ID = 6796).
    [11/07 10:03:17,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:03:17,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Uncategorized] Loader.LoadTranslatorGroups() : Translators Directory is : C:\bin\Telerik\Test Studio\Bin\Translators
    [11/07 10:03:35,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function End -------
    [11/07 10:03:36,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] TabControlViewModel constructor : Statrted Tab control in execution server
    [11/07 10:03:42,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:03:45,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Jira.BugTracking.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:45,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Load.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:45,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Manual.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.OTA.Interop.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Plugins.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Shared.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.TeamPulse.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Web.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Loading "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Wpf.dll" to find ITestStudioPkg implementers...
    [11/07 10:03:46,telerik.teststudio.exe(964:1),TestStudio] Utils.EnumPluginTypes() : Finished loading ITestStudioPkg plugins.
    [11/07 10:03:48,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator.LoadPackages() : Telerik.TestStudio.Load.LoadPkg implements ITestStudioPkg and was added as a package.
    [11/07 10:03:48,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator.LoadPackages() : Telerik.TestStudio.Manual.ManualPkg implements ITestStudioPkg and was added as a package.
    [11/07 10:03:48,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator.LoadPackages() : Telerik.TestStudio.Web.WebPkg implements ITestStudioPkg and was added as a package.
    [11/07 10:03:48,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator.LoadPackages() : Telerik.TestStudio.Wpf.WpfPkg implements ITestStudioPkg and was added as a package.
    [11/07 10:03:48,telerik.teststudio.exe(964:5)] First trace message from pool unnamed thread (managed ID = 5, native ID = 4976).
    [11/07 10:03:48,telerik.teststudio.exe(964:5),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:03:48,telerik.teststudio.exe(964:5),Uncategorized] Loader.LoadTranslatorGroups() : Translators Directory is : C:\bin\Telerik\Test Studio\Bin\Translators
    [11/07 10:03:49,telerik.teststudio.exe(964:1),Performance] PerformanceProfileViewModel.set_ViewingTimeRange() : Viewing time range overwritten: 11/7/2014 2:03:49 PM to 11/7/2014 2:03:49 PM.
    [11/07 10:03:49,telerik.teststudio.exe(964:1),Performance] PerformanceProfileViewModel.set_ViewingTimeRange() : Viewing time range overwritten: 11/7/2014 2:03:49 PM to 11/7/2014 2:03:49 PM.
    [11/07 10:03:50,telerik.teststudio.exe(964:5),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function End -------
    [11/07 10:03:51,telerik.teststudio.exe(964:4)] First trace message from pool unnamed thread (managed ID = 4, native ID = 6804).
    [11/07 10:03:51,telerik.teststudio.exe(964:4),Recording] RecorderHostService constructor : Host endpoint: net.pipe://localhost/Instance/62955/DesignCanvas/964
    [11/07 10:03:52,telerik.teststudio.exe(964:5),TestStudio] StandaloneAppSettings.LoadSettings() : Recent projects before valid check: 2
    [11/07 10:03:52,telerik.teststudio.exe(964:5),TestStudio] StandaloneAppSettings.LoadSettings() : Recent projects after valid check: 2
    [11/07 10:03:54,telerik.teststudio.exe(964:1),TestStudio] MainWindow.MainWindow_Loaded() : Test Studio (version:2014.3.903.0) started.
    [11/07 10:03:56,telerik.teststudio.exe(964:4),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:03:56,telerik.teststudio.exe(964:1),Analytics] ActivityLog.LogError() : Feature track failed!
    [11/07 10:03:57,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] PostListExecutionEmailer.CheckForValidSmtpSettings() : Unable to send email due to uninitialized SMTP settings
    [11/07 10:03:57,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:04:01,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] ProcessManager.StartProcess() : Starting profiler
    [11/07 10:04:02,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] ProcessManager.StartProcess() : EXCEPTION! (see below)
         Outer Exception Type: System.ArgumentException
         Message: Process with an Id of 6948 is not running.
         HRESULT: 0x80070057 (Official ID (if app.) = E_INVALIDARG, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_INVALID_PARAMETER)
         Call Stack:
              at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
              at System.Diagnostics.Process.GetProcessById(Int32 processId)
              at Telerik.TestingFramework.Interop.NativeProcessStarter.CreateProcessNative(ProcessStarterData data, String commandLine, Boolean suppressWindow)
              at Telerik.TestingFramework.Interop.NativeProcessStarter.Start(ProcessStarterData data, Uri path, String[] extra)
              at Telerik.TestStudio.ProcessManager.ProcessManager.CreateNativeProcess(ProcessStarterData processStarterData, String addedParameters)
              at Telerik.TestStudio.ProcessManager.ProcessManager.StartProcess(String type, String addedParameters)

    [11/07 10:04:02,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] ProcessManager.StartProcess() : Starting executor
    [11/07 10:04:02,Telerik.TestStudio.Profiler.exe(6948:1)] First trace message from process 6948: "Telerik.TestStudio.Profiler.exe" "http://xxxxxxxx.xx.xxxxxxxx.xxx:8031/" ""
    [11/07 10:04:02,Telerik.TestStudio.Profiler.exe(6948:1)] First trace message from foreground unnamed thread (managed ID = 1, native ID = 5892).
    [11/07 10:04:02,Telerik.TestStudio.Profiler.exe(6948:1),Execution] WcfHttpRawCommunicationLayer.Start() : Starting WCF Service with RawHTTP Bindings at http://xxxxxxxx.xx.xxxxxxxx.xxx:8031/
    [11/07 10:04:02,Telerik.TestStudio.Scheduling.Client.exe(2600:1),Execution] ProcessManager.StartProcess() : EXCEPTION! (see below)
         Outer Exception Type: System.ArgumentException
         Message: Process with an Id of 3964 is not running.
         HRESULT: 0x80070057 (Official ID (if app.) = E_INVALIDARG, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_INVALID_PARAMETER)
         Call Stack:
              at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
              at System.Diagnostics.Process.GetProcessById(Int32 processId)
              at Telerik.TestingFramework.Interop.NativeProcessStarter.CreateProcessNative(ProcessStarterData data, String commandLine, Boolean suppressWindow)
              at Telerik.TestingFramework.Interop.NativeProcessStarter.Start(ProcessStarterData data, Uri path, String[] extra)
              at Telerik.TestStudio.ProcessManager.ProcessManager.CreateNativeProcess(ProcessStarterData processStarterData, String addedParameters)
              at Telerik.TestStudio.ProcessManager.ProcessManager.StartProcess(String type, String addedParameters)

    [11/07 10:04:04,Telerik.TestStudio.RemoteExecutor.exe(3964:1)] First trace message from process 3964: "Telerik.TestStudio.RemoteExecutor.exe" "http://xxxxxxxx.xx.xxxxxxxx.xxx:8032/" ""
    [11/07 10:04:04,Telerik.TestStudio.RemoteExecutor.exe(3964:1)] First trace message from foreground unnamed thread (managed ID = 1, native ID = 3752).
    [11/07 10:04:04,Telerik.TestStudio.RemoteExecutor.exe(3964:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function Start -------
    [11/07 10:04:04,Telerik.TestStudio.RemoteExecutor.exe(3964:1),Uncategorized] Loader.LoadTranslatorGroups() : Translators Directory is : C:\bin\Telerik\Test Studio\Bin\Translators
    [11/07 10:04:06,Telerik.TestStudio.RemoteExecutor.exe(3964:1),Uncategorized] Loader.LoadTranslatorGroups() : ------- Function End -------
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : ------- Function Start -------
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Bug Trackers folder path is : C:\bin\Telerik\Test Studio\Bin\Plugins
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Jira.BugTracking.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : JIRA Server implements IBugTracker and was loaded in the system.
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Load.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Manual.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.OTA.Interop.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Plugins.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Error] <>c__DisplayClass4.<RegisterResolver>b__1() : EXCEPTION! (see below)
         Situation: Exception trying to resolve dependency: Microsoft.TeamFoundation.Client, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
         Outer Exception Type: System.IO.FileNotFoundException
         Message: Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=12.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
         HRESULT: 0x80070002 (Official ID (if app.) = 2147942402, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_FILE_NOT_FOUND)
         Call Stack:
              at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
              at System.Reflection.Assembly.Load(String assemblyString)
              at ArtOfTest.Common.BaseDependencyLoader.<>c__DisplayClass4.<RegisterResolver>b__1(Object o, ResolveEventArgs e)

    [11/07 10:04:17,telerik.teststudio.exe(964:4),Error] <>c__DisplayClass4.<RegisterResolver>b__1() : EXCEPTION! (see below)
         Situation: Exception trying to resolve dependency: Microsoft.TeamFoundation.Client, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
         Outer Exception Type: System.IO.FileNotFoundException
         Message: Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
         HRESULT: 0x80070002 (Official ID (if app.) = 2147942402, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_FILE_NOT_FOUND)
         Call Stack:
              at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
              at System.Reflection.Assembly.Load(String assemblyString)
              at ArtOfTest.Common.BaseDependencyLoader.<>c__DisplayClass4.<RegisterResolver>b__1(Object o, ResolveEventArgs e)

    [11/07 10:04:17,telerik.teststudio.exe(964:4),Error] <>c__DisplayClass4.<RegisterResolver>b__1() : EXCEPTION! (see below)
         Situation: Exception trying to resolve dependency: Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
         Outer Exception Type: System.IO.FileNotFoundException
         Message: Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
         HRESULT: 0x80070002 (Official ID (if app.) = 2147942402, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_FILE_NOT_FOUND)
         Call Stack:
              at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
              at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
              at System.Reflection.Assembly.Load(String assemblyString)
              at ArtOfTest.Common.BaseDependencyLoader.<>c__DisplayClass4.<RegisterResolver>b__1(Object o, ResolveEventArgs e)

    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Telerik.TestStudio.TFSBugTracker.TFSBugTracker could not be instantiated. Exception: Exception has been thrown by the target of an invocation.
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Shared.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.TeamPulse.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : TeamPulse Server implements IBugTracker and was loaded in the system.
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Web.dll"...
    [11/07 10:04:17,telerik.teststudio.exe(964:4),Uncategorized] BugTrackersLoader.LoadSystems() : Searching for IBugTracker implementers in "C:\bin\Telerik\Test Studio\Bin\Plugins\Telerik.TestStudio.Wpf.dll"...
    [11/07 10:04:19,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator.set_SelectedProject() : Active Project is : 'OMS_Regression'
    [11/07 10:04:19,telerik.teststudio.exe(964:1),Uncategorized] Orchestrator._iUIProject_ProjectOpened() : Project 'OMS_Regression' Ready.
    [11/07 10:04:22,telerik.teststudio.exe(964:11)] First trace message from pool unnamed thread (managed ID = 11, native ID = 6132).
    [11/07 10:04:22,telerik.teststudio.exe(964:11),TestStudio] <>c__DisplayClassf.<LoadInternal>b__9() : Extract elements time: 00:00:00.9406176
    [11/07 10:04:22,telerik.teststudio.exe(964:11),TestStudio] <>c__DisplayClassf.<LoadInternal>b__9() : Total Elements count: 127
    [11/07 10:09:27,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function Start -------
    [11/07 10:10:21,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function End -------
    [11/07 10:10:24,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function Start -------
    [11/07 10:22:33,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function End -------
    [11/07 10:22:41,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function Start -------
    [11/07 10:26:45,telerik.teststudio.exe(964:1),ProjectModel] DataHelper.CreateData() : ------- Function End -------


  2. Answer
    Cody
    Admin
    Cody avatar
    3354 posts

    Posted 11 Nov 2014 Link to this post

    Hi Alan,

    There appears some confusion on what happens under the covers when you add a new data source. Test Studio actually wants to grab the file you select and copy it to the Data folder of the test project. It appears in your screen shot you are selecting an Excel file from the same Data folder for the test project. If it's in the Data folder there's no need to add it i.e. no need to "Create new data source". You only need to select a test and bind to the already existing data source. You're getting the message "File ... already exists" because it's already located in the Data folder that Test Studio is trying to copy it into.

    Then you're getting the "File ... doesn't exist" because you're entering the name to a non existent Excel file when Test Studio wants to find an already existing file at that location so it can copy it to the Data folder.

    I hope this helps clear up the confusion.

    Regards,
    Cody
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top