This is a migrated thread and some comments may be shown as answers.

Browser is hanging

1 Answer 22 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Hari
Top achievements
Rank 1
Hari asked on 29 Aug 2013, 10:09 AM
Hi Support Team,

I am using WebAii testing framework(V 2012.2.1420.0), Using Visual studio test explorer to run my automated test cases.
Followed below steps to run the test cases in RUN mode:

1) In local.testsettings file > Test Timeouts tab > set 2mins for indivisual test execution field and unselect checkbox for total execution time field

2) Created a test list of say 5 test cases in VS2012

3) First test will abort after 2 minutes. (as it reached time out)

5) Second test will start notice that the browser hangs and user can't logon and test aborts after two minutes

6) Step 5 is repeats for all test cases

Plase assist me on this. why browser is hanging from second test cases execution?

Using IE9(v 9.0.8112.16421)

Thanks,
Hari


1 Answer, 1 is accepted

Sort by
0
Velin Koychev
Telerik team
answered on 02 Sep 2013, 01:50 PM
Hello Hari,

I am sorry to hear that  you are experiencing this issue.


Can you verify whether IE browser closes after the first test fails? If not, you can try to set KillBrowserProcessOnClose to True. This will make sure that the browser process is killed when closing the browser. 

I hope this helps.

Regards,
Velin Koychev
Telerik
The New Release of Telerik Test Studio Is Here! Download, install,
and send us your feedback!
Tags
General Discussions
Asked by
Hari
Top achievements
Rank 1
Answers by
Velin Koychev
Telerik team
Share this question
or