3 posts, 0 answers
  1. Mayank
    Mayank avatar
    2 posts
    Member since:
    Nov 2015

    Posted 04 Nov 2015 Link to this post


    This post is regarding automatic ReRun of failed tests in a Test list.

    I have followed all the steps provided in another post on same subject:


    But my falied tests doesnot rerun after the test list execution gets completed.

    Steps followed :

    1) Downloaded the DLL and config file.
    2) Pasted the files @ "C:\Program Files\Telerik\Test Studio\Bin".
    3) Executed test list containing a test that fails.
    4) Executed the list and rerun is not done.
    5) Restarted Telerik Test Studio and again executed the same list.
    Issue: Still the failing test is not executed again.
    Operating System is Windows 7(Service Pack 1, RAM 4 GB, System Type : 32 bit)

    Does this solution provided by you guys work only on 64 bit operating system?
    Or i am missing something over here?​

  2. Daniel Djambov
    Daniel Djambov avatar
    87 posts

    Posted 06 Nov 2015 Link to this post


    What I can see is that you did not paste the .dll and the config file in 'C:\Program Files\Telerik\Test Studio\Bin\Plugins\' folder, but in 'C:\Program Files\Telerik\Test Studio\Bin'.

    Can you ensure they are copied at the right location and give it another try?

    If this does not work, can you check the Test Studio log file to see if there is any exception when the test list is run?

    I'm not aware of any limitations for a 32 bit Windows, but the source code of the plugin is also available in the forum post, so you can modify it and build it at your environment first, then add it to the Plugins folder.

    Please tell me if the above suggestions worked for you.

    Best Regards,
    Daniel Djambov
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Mayank
    Mayank avatar
    2 posts
    Member since:
    Nov 2015

    Posted 16 Nov 2015 in reply to Daniel Djambov Link to this post

    Thanks! Daniel

    you were correct the path was incorrect, but even after correcting that, rerun didn't take place, then i checked that the path of the "ProcessToRun" tag in RERunFailedTests.dll config file had to be changed to Win 32 bit path (Program Files (x86) to Program Files).

    Even after that it wasn't working fine, then as suggested by you i checked the logs and found that we need to enter :

        <loadFromRemoteSources enabled="true"/>

    inside <Configuration> tag after <appSettings>.

    Then it worked fine. :)
Back to Top