Telerik Forums
Telerik Control Panel Forum
4 answers
90 views

I have configured the Control Panel to install my Telerik selection into "V:\Telerik".One entry in that directory is a folder "ToolboxNuGetPackages".

Last night I updated the Telerik libraries to the current version using the Progress Control Panel. A few minutes ago, I created a new solution for a WPF netcoreapp (in Jetbrains Rider), added references to the required Telerik libraries and tried to build the otherwise untouched solution.

It failed during the ResolvePackageAssets task, because nuget was unable to find the fallback package folder "C:\Program Files (x86)\Progress\ToolboxNugetPackages".

With a bit of help from StackOverflow I found that this setting is defined in the file "C:\Program Files (x86)\NuGet\Config\Telerik UI for WPF.config", and I for one did not put it there. In fact, I had changed it a few days ago,while investigating some other build failures; after all, it was a non-existing path, so things could not get worse. Now, after the update, the original path is back ... and as installer the Control Panel is my prime suspect.

So I'd like to ask somebody at Telerik to check if the Control Panel does write the contents of that file and if so, to make sure that it uses the actual location of the ToolboxNuGetPackages folder. 

In my case, I changed the path to "V:\Telerik\ToolboxNuGetPackages", unloaded and reloaded the project and it built without further problems.

 

I tried to submit this via the "Get Technical Support" item in my account page, but the UI is so user-friendly that submissions for the Control Panel are impossible there.

 

Kind regards,

Stefan

Nikola
Telerik team
 answered on 18 Aug 2020
1 answer
7 views

     Hello, i'm trying to reinstall my computer, i had a licence until july 2019, when i try to download last versiĆ³n i paid for there is nothing to donwload, how can i get the las version included in my subscription?

 

thank you

Nikolay Mishev
Telerik team
 answered on 05 Aug 2020
3 answers
16 views

I have RadButtonLink  which fires method to download image from server side without refreshing the page, but this RadButtonLink located under RadPanelBar which make it unassailable, how to solve this issue? 

 

```

<asp:Content ContentPlaceHolderID="CPHMain" ID="Content1" runat="server"><div class="ChildBody"><asp:UpdatePanel ID="UpdatePanel1" runat="server"><ContentTemplate><Telerik:RadPanelItem runat="server" Expanded="false" Selected="true" Text="Virtual Card Display"><Items><Telerik:RadPanelItem runat="server" Value="VirtualCardDisplay"><ItemTemplate><div class="container1"><div class="box1"><div class="part-1" style="white-space: nowrap; flex: 0 0 25% !important"><asp:ImageButton ID="imgDownloadLarge" runat="server" Height="11pt" ImageAlign="AbsMiddle" ImageUrl="../../MasterTemplate/Images/download_png_icon.png" OnClientClick="lnkDownloadLarge_Click1" Width="11pt" ToolTip="Download image" /><Telerik:RadLinkButton ID="lnkDownloadLarge1" runat="server" CssClass="LinkAction" Text="Download Large Image" OnClick="lnkDownloadLarge_Click1"><Icon CssClass="rbDownload"></Icon></Telerik:RadLinkButton></div><div class="part-2" style="white-space: nowrap; flex: 0 0 75% !important"><asp:Label ID="lblLargeImageResponse" runat="server" ForeColor="Red" Text=" "></asp:Label></div></div></div></ItemTemplate></Telerik:RadPanelItem></Items></Telerik:RadPanelItem></ContentTemplate></asp:UpdatePanel></div></asp:Content>

```

Vessy
Telerik team
 answered on 20 May 2020
2 answers
4 views

Hello All,

I need your help regarding display grid inside kendo treeview using single file component in Vue.

I have attached image file for my requirement please help me.

Rahul
Top achievements
Rank 1
 answered on 28 Nov 2019
5 answers
57 views

Hi,

On my new PC, Telerik control panel doesn't install (fresh download). It crashes without displaying any UI and logs the folliwng error in Event Log:

 

Application: ProgressControlPanel.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
   at Telerik.CommonInstaller.DataAccess.ProductVersionServiceWrapper.get_Instance()
   at Telerik.CommonInstaller.Detection.Helpers.VisualStudioDetector.InitializeVisualStudioWrappers()
   at Telerik.CommonInstaller.Detection.Helpers.VisualStudioDetector..ctor()
   at Telerik.CommonInstaller.Detection.Helpers.VisualStudioDetector.get_Instance()
   at Telerik.CommonInstaller.Detection.InstallationDetector..ctor(Telerik.CommonInstaller.SystemWrappers.Registry.Interfaces.IRegistryOperator, Telerik.CommonInstaller.SystemWrappers.FileSystem.IFileSystemOperator, Telerik.CommonInstaller.MsiWrappers.WindowsInstaller.IWindowsInstallerDetector, Telerik.CommonInstaller.Detection.Helpers.GacSearcher, Telerik.CommonInstaller.Detection.Helpers.IVersionOperator)
   at Telerik.CommonInstaller.Detection.InstallationDetector..ctor()
   at Telerik.CommonInstaller.ControlPanel.Program.GetApplicationFilePath()
   at Telerik.CommonInstaller.ControlPanel.Program.TryLaunchInstalledApplication()
   at Telerik.CommonInstaller.ControlPanel.Program.Main()

Is there any workaround for this?

Nick

 

Nikolay Mishev
Telerik team
 answered on 10 Oct 2019
5 answers
10 views

So we have a couple of licenses for DevCraft Complete.  The control panel lists a lot of the products in that package as having a trial license.  We are confused as to why it is showing that status.  For instance, KendoReact is PURCHASED, but Kendo UI for Vue is showing TRIAL  In addition, when we click on "Get Started", it takes us to a page to buy now or start a free trial.  Why is it trying to sell us something we already own?

I've been trying to talk another team into using your product, but the licenses are not cheap.  Things like this may keep them from pulling the trigger.

Is this fixable, or can you give me something I can throw their way as an explanation?

Thanks!

Yana
Telerik team
 answered on 19 Jun 2019
1 answer
9 views

.cshtml in View:

@(Html.Kendo().Grid<Main_Kendo.Models.ScannerViewModel>()

.Name("Grid")        

    .Columns(columns =>       

{            

columns.Bound(b => b.Scan).Width(140);            columns.Bound(b => b.BarcodeImage).Width(140);            columns.Bound(b => b.DropZone).Width(140);            columns.Bound(b => b.EnteredBy).Width(100);            columns.Bound(b => b.EnteredDate).Width(130);            columns.Command(command => command.Destroy()).Width(110);        })

Viktor Tachev
Telerik team
 answered on 14 May 2019
5 answers
123 views

Stuck at download either choice add other items or leave as included, but still stuck at downloading step 114 MB...  Tried to uncheck VS 2013 and 2017 then included 2013 and 2017, nothing go far... 

Thank you

Nikolay Mishev
Telerik team
 answered on 28 Mar 2019
5 answers
50 views

As the title suggest, when I install Terlik controls by running the control panel as a local administrator account, the tools don't properly setup in Visual Studio 2017 for my standard account.

Due to company policy, installations on our desktop have to be completed with an administrator account different than our regular user account.    So, the only way for me to install the tools is via a different account.   This installation "works", and all Telerik is installed on my desktop, but Visual Studio does not recognize Telerik when I run my standard account which is used for development (see "StandardView.jpg" attached).

If I run Visual studio under the administrator account, the Telerik menus, toolbars, etc.. show up in Visual Studio (see "RunAsAdmin.jpg" attached), but then I am unable to develop due to our security policy restrictions.  I have to develop in an account different than this administrator account, but cannot with the Telerik tools.

Is there a method to make this automatically install for my standard account as well when installing with the admin account?

 

Thanks,

Russell

Vesko
Telerik team
 answered on 07 Mar 2019
6 answers
25 views
 The message I am getting is 'Unexpected error has occurred' and on the next line 'Failed to receive data from Telerik web service'.  I ran this yesterday with no problems (and have been for a long time).  Are you having issues with your service?
Vesko
Telerik team
 answered on 21 Jan 2019
Narrow your results
Selected tags
Tags
+? more
Top users last month
Matthias
Top achievements
Rank 5
Bronze
Bronze
Iron
Psyduck
Top achievements
Rank 4
Bronze
Bronze
Iron
Liu
Top achievements
Rank 1
Iron
Alex
Top achievements
Rank 1
Veteran
Iron
Iron
George C.
Top achievements
Rank 2
Iron
Veteran
Top users last month
Matthias
Top achievements
Rank 5
Bronze
Bronze
Iron
Psyduck
Top achievements
Rank 4
Bronze
Bronze
Iron
Liu
Top achievements
Rank 1
Iron
Alex
Top achievements
Rank 1
Veteran
Iron
Iron
George C.
Top achievements
Rank 2
Iron
Veteran