z-index on the menu

8 posts, 0 answers
  1. Faris Rezek
    Faris Rezek avatar
    8 posts
    Member since:
    Nov 2009

    Posted 14 Feb 2010 Link to this post

    hi
    i made a custom skin for the menu.
    but the z-index of the  sub items not so big.
    on my page i also have rad window.
    where i can change the z-index of the sub-items  of the skin, so the subitems of the menu will be above the rad - windows
    i deveoping these website
    http://213.154.244.55/EfFect/index.aspx
    username: was
    password:  was
  2. Yana
    Admin
    Yana avatar
    4841 posts

    Posted 15 Feb 2010 Link to this post

    Hello Faris,

    Please check this help article  which explains how to fix this issue.

    Kind regards,
    Yana
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Faris Rezek
    Faris Rezek avatar
    8 posts
    Member since:
    Nov 2009

    Posted 16 Feb 2010 Link to this post

    hello it
    doesnot help.
    i need to change thezIndex of the menu subitems .
  4. Yana
    Admin
    Yana avatar
    4841 posts

    Posted 17 Feb 2010 Link to this post

    Hello Faris Rezek,

    Which browser you're usinh? I've tested the site in Firefox and IE8 ana it works without a problem.

    All the best,
    Yana
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Faris Rezek
    Faris Rezek avatar
    8 posts
    Member since:
    Nov 2009

    Posted 17 Feb 2010 Link to this post

    it is work fine on Chrome
    the problem is on IE7.
    it is so important for us to solve these other wise my customer will became not happy.
  6. Yana
    Admin
    Yana avatar
    4841 posts

    Posted 23 Feb 2010 Link to this post

    Hello Faris,

    I'm afraid that this is a bug in IE7 regarding stack order of elements on the page as it's explained here.
    You should remove "position: absolute" css rule from the following elements in order to work-around it:
     - element with id="loadWindow";
     - element with class="CenterPage";
     - the table inside element with id="menuDiv".

    I hope this helps.

    Greetings,
    Yana
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. benitolopez_sistemas
    benitolopez_sistemas avatar
    25 posts
    Member since:
    Jan 2007

    Posted 26 Feb 2010 Link to this post

    Can you please share a sample with this kind of solution?
  8. Yana
    Admin
    Yana avatar
    4841 posts

    Posted 02 Mar 2010 Link to this post

    Hello benitolopez,

    It depends on the specific situation. Can you send us a live url where we could observe the issue?

    Kind regards,
    Yana
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top