This is a migrated thread and some comments may be shown as answers.

Using r.a.d.editor in List Items

10 Answers 137 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
mdwebguy
Top achievements
Rank 1
mdwebguy asked on 05 Mar 2007, 06:58 PM
When I follow the instructions and active the Item feature it never replaces the the stanard text control.  I can add it as a web part.  I trade restarting multiple times, activing and deactiving it, never replaces on any of the item lists.

10 Answers, 1 is accepted

Sort by
0
Chip
Top achievements
Rank 1
answered on 06 Mar 2007, 08:53 AM
Are you using IE?

The rad editor does not show up for list items in IE. There is a sticky topic that explains this - http://www.telerik.com/community/forums/thread/b311D-tbkak.aspx
0
mdwebguy
Top achievements
Rank 1
answered on 06 Mar 2007, 06:22 PM
I'm using IE and I can get it to work as a web part, but i won't change the default text editor to RADeditor.  When you click the activate button it's supposed to override the default one.
0
mdwebguy
Top achievements
Rank 1
answered on 06 Mar 2007, 06:25 PM
wow that's just stupid.  Ok, thanks.
0
Chip
Top achievements
Rank 1
answered on 07 Mar 2007, 08:48 AM
Well, it seems that Microsoft allowed Telerik (see the last posts near the bottom) to replace the List editor in IE too so we'll be getting RadEditor in List in all browsers pretty soon :)
0
Lini
Telerik team
answered on 07 Mar 2007, 03:17 PM
Hi guys,

As we already stated, the next release for the MOSS editor is scheduled about a month from now and in it, you can expect an option to use our list editor in IE too.

All the best,
Lini
the telerik team
0
Marja
Top achievements
Rank 1
answered on 01 Jan 2009, 05:30 PM
Dear All,

It still doesn't seem to work.
or is it me?

Kind Regards,
Marja Beckers
0
Stanimir
Telerik team
answered on 02 Jan 2009, 09:07 AM
Hi Marja,

Could you please tell us which version of the RadEditor for MOSS you are using. Also please give us more information about the problem that you have.

Once you do this we will be glad to help  you further.
Thank you.


Kind regards,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Marja
Top achievements
Rank 1
answered on 02 Jan 2009, 09:58 AM
Dear all,
I am using the latest Lite version 4.5.4 (I donwloaded it 2 days ago).
When I follow the instructions and activate the "use rad editor to edit list items" & "use rad editor to edit list items in internet explorer as well", I still only get the standard sharepoint (moss 2007) editor.

Kind Regards,
Marja Beckers
0
Stanimir
Telerik team
answered on 05 Jan 2009, 12:43 PM
Hello Marja,

Please try the following steps.

1. Go to a List item page. For example Wiki or Blog.
2. From the Site Actions menu go to Site Settings > Modify All Site Settings
3. Click Site features in the Site Administration column.
4. Scroll to the bottom of the list and activate the Use RadEditor to edit List Items feature.
5. IMPORTANT! If you still see the default editor or a simple textbox after you activate the RadEditor feature(s), you might need to open a command prompt window and type iisreset to reset the Internet Information Server. This will prevent problems caused by caching.

I hope this helps.


Best wishes,
Stanimir
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Marja
Top achievements
Rank 1
answered on 05 Jan 2009, 02:30 PM
Dear All,

I created a wiki site & got it to work ok.
It only seems it's not using my customized toolsfile.xml, cause it's only showing the default fonts & classes.
It works ok in the radeditor webpart.

Kinds regards,
Marja
Tags
WebParts for SharePoint
Asked by
mdwebguy
Top achievements
Rank 1
Answers by
Chip
Top achievements
Rank 1
mdwebguy
Top achievements
Rank 1
Lini
Telerik team
Marja
Top achievements
Rank 1
Stanimir
Telerik team
Share this question
or