This is a migrated thread and some comments may be shown as answers.

Toolbox Configurator does nothing

4 Answers 183 Views
Installer and VS Extensions
This is a migrated thread and some comments may be shown as answers.
Ed Lance
Top achievements
Rank 1
Ed Lance asked on 15 Sep 2011, 12:43 AM
Win 7 64 bit, VS 2010 Pro.

I have installed the Q2 release.  I still see the Q1 items on the VS toolbox (Q1 2011 NET 40).  When I open the Toolbox Configurator, it allows me to choose the new release in the drop down v.2011.2..712.40.  It restarts VS, but nothing has changed, the Q1 items are there, the Q2 items are not.

4 Answers, 1 is accepted

Sort by
0
Teodor
Telerik team
answered on 15 Sep 2011, 09:51 AM
Hi Ed,

I'm afraid your toolbox cache may have been corrupted. You can make a full reset of the toolbox by deleting the cache to make sure it is working properly. Note that this will revert the toolbox to its default state. To reset the toolbox follow these steps:

  1. Close all Visual Studio 2010 instances.
  2. Open Windows Explorer and navigate to the location: %localappdata%\Microsoft\VisualStudio\10.0
  3. Delete all .tbd files (note that some of them are hidden);
  4. Open a web project in Visual Studio and check whether the toolbox shows the controls properly.

Hope we get the issue resolved soon.

Kind regards,
Teodor
the Telerik team
Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal
0
Ed Lance
Top achievements
Rank 1
answered on 15 Sep 2011, 06:00 PM
Thanks.

I already ran the Telerik set up again and that fixed the toolbox.  But I'll keep this in mind.
0
The Kawa Dev
Top achievements
Rank 1
answered on 04 Apr 2012, 05:19 PM
Hi Teodor,

I ran into the same issue as Ed
(v.2012.1.321.40)

I tried your recommendation, appending .old to the two .tbd files in the directory.

Started VS2010, re-ran the Toolbox configurator with no luck.
 
I will try a repair install next, but if you have any additional workarounds I can give them a go first.

Thank you,
- Jordan
0
Govinda
Top achievements
Rank 1
answered on 04 Sep 2012, 06:39 PM
@Teodor,
thanks for the workaround. I was have the same problem with not being able to add controls through the Toolbox Configurator. Once I delted the .tdb files and restarted VS, the Telerik controls were there.

Thanks again!
Govinda
Tags
Installer and VS Extensions
Asked by
Ed Lance
Top achievements
Rank 1
Answers by
Teodor
Telerik team
Ed Lance
Top achievements
Rank 1
The Kawa Dev
Top achievements
Rank 1
Govinda
Top achievements
Rank 1
Share this question
or