This is a migrated thread and some comments may be shown as answers.

Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=ScriptManager1_TSM

7 Answers 494 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Nahji
Top achievements
Rank 1
Nahji asked on 20 Dec 2013, 04:35 PM
error: Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=ScriptManager1_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d4.0.0.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3aen-US%3af01b1325-3d40-437a-8da2-df3d86714220%3aea597d4b%3ab25378d2

my web config below:

PLEASE HELP!  Been stuck for 2 days

<?xml version="1.0"?>
<!-- 
    Note: As an alternative to hand editing this file you can use the 
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in 
    machine.config.comments usually located in 
    \Windows\Microsoft.Net\Framework\v2.x\Config 
-->
<configuration>
  <appSettings configSource="appsettings.config" />
  <connectionStrings>

  </connectionStrings>
  <system.web>
    <sessionState timeout="120" />
    <!-- 
            Set compilation debug="true" to insert debugging 
            symbols into the compiled page. Because this 
            affects performance, set this value to true only 
            during development.
        -->
    <!--
      Set compilation debug="true" to insert debugging
      symbols into the compiled page. Because this
      affects performance, set this value to true only
      during development.
    -->
    <compilation debug="true" targetFramework="4.0">
      <assemblies>
        <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
      </assemblies>
    </compilation>
    <!--
            The <authentication> section enables configuration 
            of the security authentication mode used by 
            ASP.NET to identify an incoming user. 
        -->
    <authentication mode="Windows" />
    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
      <controls>
        <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />
      </controls>
    </pages>
    <httpHandlers>
      <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
      <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
      <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode,runtimeVersionv2.0"/>
      <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
    </httpHandlers>
    <httpModules>
      <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" />
      <add name="RadCompression" type="Telerik.Web.UI.RadCompression" />
    </httpModules>
    <!--
            The <customErrors> section enables configuration 
            of what to do if/when an unhandled error occurs 
            during the execution of a request. Specifically, 
            it enables developers to configure html error pages 
            to be displayed in place of a error stack trace.

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
    <customErrors mode="RemoteOnly" />
  </system.web>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules runAllManagedModulesForAllRequests="true">
      <remove name="RadUploadModule" />
      <remove name="RadCompression" />
      <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" preCondition="integratedMode" />
      <add name="RadCompression" type="Telerik.Web.UI.RadCompression" preCondition="integratedMode" />
    </modules>
    <handlers>
      <remove name="ChartImage_axd" />
      <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
      <remove name="Telerik_Web_UI_DialogHandler_aspx" />
      <remove name="Telerik_RadUploadProgressHandler_ashx" />
      <remove name="Telerik_Web_UI_WebResource_axd" />
      <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
      <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
      <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
      <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode" />
      <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
    </handlers>
  </system.webServer>
  <system.web.extensions>
    <scripting>
      <webServices />
    </scripting>
  </system.web.extensions>
</configuration>

7 Answers, 1 is accepted

Sort by
0
Peter Filipov
Telerik team
answered on 25 Dec 2013, 06:34 AM
Hi Nahji,

I have tested the web config and everything is working fine. Could you try to replace the following line:
<add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode,runtimeVersionv2.0"/>
with:
<add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />

Is it possible to send a stripped version of your project to test it locally.

Regards,
Peter Filipov
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Daniel
Top achievements
Rank 1
answered on 09 Apr 2014, 03:49 AM
That isn't a valid configuration, when I try to use that it reports an IIS error and says you need the attribute "name".
0
Peter Filipov
Telerik team
answered on 11 Apr 2014, 02:02 PM
Hello Daniel,

Try the following configuration (remove the runtime version):
<add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode"/>


Regards,
Peter Filipov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Alexander
Top achievements
Rank 1
answered on 17 Sep 2014, 04:33 PM
Hello Peter, Thanks please this problem already has a solution ? I've seen suggesting telerik , but does not work..
0
Peter Filipov
Telerik team
answered on 18 Sep 2014, 10:11 AM
Hi Alexander,

When the handler is added with the smart tag of the RadScriptManager the declaration in the web.config should be correct. In case that you have an issue please open a new support ticket and send us a sample project.

Regards,
Peter Filipov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
syed
Top achievements
Rank 1
answered on 26 Jan 2015, 08:48 AM
Hello I am facing same issue.Could you please share with me if you have any answers?
0
Peter Filipov
Telerik team
answered on 28 Jan 2015, 09:15 AM
Hello Syed,

Could you send me your project to test it locally? You could open a new support ticket and attach it.

Regards,
Peter Filipov
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
VeriFone
Top achievements
Rank 1
commented on 08 Apr 2022, 05:24 AM

We are also facing similar issue. Please advise what is the fix for this? 
Vessy
Telerik team
commented on 08 Apr 2022, 07:29 AM

Hi VeriFone, the root of the initial issue of this thread was the preCondition="integratedMode,runtimeVersionv2.0". Can you verify that you do not have such setting at our end? If this is not the case, can you attach your web.config here (or in a private ticket), so we can examine it further?

VeriFone
Top achievements
Rank 1
commented on 11 Apr 2022, 10:48 AM

We do not have preCondition="integratedMode,runtimeVersionv2.0"

What we have is - preCondition="integratedMode"

Vessy
Telerik team
commented on 12 Apr 2022, 07:02 AM

Hi VeriFone,

The preCondition="integratedMode" is the proper one and should not be causing any problems. As you have already opened a private ticket on the same matter, I would advise that you try the suggestions given by Attila and reply with any further questions in there, so we can have the whole information at one place. As the ticket with Attila is private, you can also attach the web.config for review there.

Tags
General Discussions
Asked by
Nahji
Top achievements
Rank 1
Answers by
Peter Filipov
Telerik team
Daniel
Top achievements
Rank 1
Alexander
Top achievements
Rank 1
syed
Top achievements
Rank 1
Share this question
or