This is a migrated thread and some comments may be shown as answers.

'Telerik' Undefined

5 Answers 102 Views
Ajax
This is a migrated thread and some comments may be shown as answers.
Adam
Top achievements
Rank 1
Adam asked on 10 Jul 2008, 08:10 PM
Error on Page Load - 'Telerik' Undefined

I've searched for this error throughout the Forums and found several references to this error concerning Vista and IIS 7.0, however, I'm receiving this error on page load in IE 6 SP1 only. It works well on IE 7 and Firefox.

I have a RadAjax Panel, Loading Panel, 1 Textbox, 2 combo boxes and 1 Gridview.

Any help would be greatly appreciated.

5 Answers, 1 is accepted

Sort by
0
Konstantin Petkov
Telerik team
answered on 11 Jul 2008, 05:47 AM
Hi Adam,

The error is indeed widely discussed in the forums. Since your case is a different one, we will definitely need more information regarding your scenario. Can you please try to isolate the error removing parts of your markup/code and see what is causing it? You can also send a stripped down runnable project which replicates the issue through a formal support ticket. Thank you!

Kind regards,
Konstantin Petkov
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
ACruz
Top achievements
Rank 1
answered on 05 Aug 2008, 05:18 PM
Hello All,

I am sorry to get myself into this discussion, but i have the exact same problem on a customer.

The thing is that it is not specific to a browser, but specific to a group in the company Active Directory...

Our findings so far point to group policies specified on the AD. They currently have mixed (2000 + XP + VISTA) policies, since on the same workstation one user has telerik is undefined, and another user works just fine.

just for notice: Java script is enabled!

My question is, is this situation similar to your problem?

Is there any AD policy that can affect "Telerik ASP.net Ajax controls"?

Thank you.
0
Sebastian
Telerik team
answered on 06 Aug 2008, 07:17 AM
Hi guys,

I think that the following help article which elaborate on how to troubleshoot web resources or 'Telerik is undefined' errors under Vista/IIS7 will help you address the erroneous behavior you encountered:

http://www.telerik.com/help/aspnet-ajax/troubleshooting.html
http://www.telerik.com/help/aspnet-ajax/web-resources-troubleshooting.html

Best regards,
Stephen
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
ACruz
Top achievements
Rank 1
answered on 06 Aug 2008, 11:26 AM
Hello all,


The thing is, the same application on the same server and same workstation works on some users and not on others.

The hosting is beeing done on IIS6.

The link you provided, shows "usual" problems with the application and some switches usually forgotten.

It is related to the User due to some Active Directory policies, that i was unable to determine yet.

I am still looking for this issue, and it affects only a handfulll of users, and since it is a Infrastruture problem i am really not that worried (They should reset the policies).

But it point that Active Directory policies can affect the Telerik controls. 

The answer i was looking for is which combination of policies can cause telerik/Ajax not to work.

The only thing i have is the error on the user (Telerik is undefined) (HTML renders just fine).

Thank you,
Leandro Teixeira


0
Pavel
Telerik team
answered on 07 Aug 2008, 09:51 AM
Hi Leandro,

We have not received other reports for such issues before. Given the little information available on the problem and the fact that it concerns only some of your users, we cannot provide any useful advice. If you manage to acquire more details about the problem, do let us know.

Best wishes,
Pavel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Ajax
Asked by
Adam
Top achievements
Rank 1
Answers by
Konstantin Petkov
Telerik team
ACruz
Top achievements
Rank 1
Sebastian
Telerik team
Pavel
Telerik team
Share this question
or